Intel vPro® Platform
Intel Manageability Forum (Intel® EMA, AMT, SCS & Manageability Commander)
2645 Discussions

AMT SDK RemoteControlTyped/Untyped.exe aborts during enumerate

Community Manager

Hi experts,

I have two laptops - one is a vPro enabled and another is a non-vPro laptop. I successfully built the RemoteControlTyped and RemoteControlUntyped.exe applications that are part of the SDK on my non-vPro laptop. Here is what I tried:

remotecontroltyped.exe -c -verbose -host -user admin -pass

What I see is a "Debug Assertion Failed"

Expression: map/set iterator not dereferenceble.

So I tried to pass the arguments into the IDE(visual studio 2008) and run in debug mode where I set breakpoints. I see that it hits this error when attempting to perform an Enumerate on Cim_RegisteredProfile.

Since I am fairly new to this stuff I am looking for help on what could be causing and what I can do to get past this. Is there some other application I need to run before running the remote control? I did not quite figure out what it is trying to enumerate.

Appreciate your help.


Sudarsan VS.

0 Kudos
1 Reply
Community Manager


let me ask you some questions about your system to see how can we help you:

  1. Did you provisioned/configured your AMT?


  2. Which AMT version do you have?


  3. Are you working over a secure tunnel?


  4. Does the following URL (anable to contact AMT via browser also named as "Web UI") works for you: http://yourAMTadress:16992/index.htm http://yourAMTadress:16992/index.htm


After having some answer i am sure we can progress prrety fast.