Intel vPro® Platform
Intel Manageability Forum (Intel® EMA, AMT & Manageability Commander)
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
2663 Discussions

Can a bad Core i7 940 processor (or poor placement in socket) cause memory to be lost?


I was running the above proc on a DX58SO mobo with 6 GB of DDR-3 RAM. The Southbridge chip burnt out because a tech knocked the heat sink off of it. There certainly could have been damage to the processor and/or the memory when this happened.

Processor and RAM moved to an ASUS P6T mobo (was available). The system boots and I loaded windows but get too many Blue Screens. I believe the system H/W is unstable. The BIOS reports that there is only 4087 MBytes of RAM. When I move the DIMMs around using them 2 at a time, all combinations of 2 result in 2037 MBytes recognized in the BIOS. (I am guessing that means the memory is all good or all bad.) I also tried manually setting memory timing to match the Mushkin 991585 timing and set the voltage manually to 1.5V. The timing changes resulted in a an overclock error. (I then set things back where they were to start.)

Should I be worried about the processor? Can a bad processor or a badly seated processor produce these symptoms? Does anyone have any recommendations for things to test or try?



0 Kudos
2 Replies

I just purchased a Asus P6T MOBO, an i& 920, and a 6G Kingston memory kit (3x2), I can only get the BIOS to recognise available memory as 4087. The board specs state to populate A1, B1, and C1. It appears that A1 is not being recognized. I have tried all combination of chip placements, and same result so I am confident the memory is OK. I have seen numerous posts on various boards about this problem - there appear to be some 'fixes', but I have not found one the is clearly solving mine. Some claim a bent processor pin. Others, it is some other 'reason'. But I none so far fix my problem. I am considering retruning the MOBO and going with a different vendor. I am really at a loss as to what to do next.


In my case, it turned out that the memory was not compatable with the ASUS mobo.

I installed the processor and the same memory and my i940 processor onto a new Intel DX58SO MOBO and everything worked great.

Good luck on your problem.