Intel vPro® Platform
Intel Manageability Forum for Intel® EMA, AMT, SCS & Manageability Commander
2761 Discussions

KVM remote control only working when OS is running



I'm trying to configure vPro for kvm remote control on HP DC 8100.

I'm using VNC free edition and vnc viewer plus for this purpose.

Remote control works fine if windows is running but when entering Bios, I just can see the remote screen but keyboard control is not running.

Any idea how to solve this ?

Best regards,


0 Kudos
3 Replies

KVM remote control uses simulated USB 2.0 keyboard and mouse input. It's possible that the BIOS has USB legacy support turned off. This is an educated guess, but I'm thinking that USB legacy would need to be on for BIOS and DOS based applications to function with the keyboard. Will you check this setting and let me know if it helps?

If it doesn't help, please provide your BIOS version and ME Firmware version and I'll do some more investigation. Also, you might just want check with HP and see if there's a known issue and/or BIOS/firmware upgrade available.

Anyhow, let me know what you find.

0 Kudos

It seemes that there is no BIOS option for "USB legacy support"

Here is the info from HP :I

The system BIOS ROM checks the USB port, during POST, for the presence of a USB keyboard.

This allows a system with only a USB keyboard to be used during ROM-based setup and also on

a system with an OS that does not include a USB driver.

On such a system a keystroke will generate an SMI and the SMI handler will retrieve the data

from the device and convert it to PS/2 data. The data will be passed to the keyboard controller

and processed as in the PS/2 interface. Changing the delay and/or typematic rate of a USB

keyboard though BIOS function INT 16 is not supported.

I also updated Firmware and BIOS but the problem is not solved

Thanks for your help.

0 Kudos

How are you trying to get into the BIOS?

I finally found an HP DC8100. Mine had BIOS v 1.0.7 so I updated to 1.13. Once I did that, I am able to get into BIOS using Real VNC Viewer Plus. Here's how I do it:

While DC8100 is in windows, connect via KVM. Using windows start menu to do a graceful reboot. During boot, press F10. System goes into BIOS and keyboard works. Also, I was able to send an F8 key (using the viewer's menu option) to get into Win7's boot loader options.

Just to be sure, I poked around in the BIOS to see if anything looked like it would be effecting the success of this opertation. However, nothing jumped out at me.

Next I tried this: While DC8100 is in windows, connect via KVM. From the viewer's power control menu, select reset, then boot to BIOS. Click reset. Note: this is a forced reboot. Windows will not get a chance to shut down gracefully. You have been warned. OK, on my system, it ran POST, then entered BIOS. My keyboard worked.

At this point I'm not really sure what to think. You may try the steps above as I outlined. You may also double check your BIOS version and upgrade you ME firmware version as well. Mine has, which is also on HP's web site. Further, you may try to unconfigure and re-configure AMT. However, if all that fails, my next recomendation would be to work with HP directly.

BTW - it should not matter, but just in case, my system is provisioned locally with MEBx. I am using the admin user account and I do not have Kerberos or TLS's the most basic AMT config possible. Also, I am using Real VNC Viewer Plus v 1.1. Both my HP and console system have Win7.

Please let me know if you have any Qs or if I can help any further.

0 Kudos