Intel vPro® Platform
Intel Manageability Forum (Intel® EMA, AMT, SCS & Manageability Commander)
2641 Discussions

Laptop shutting down exactly after 30 min (even when left in BIOS)

Sunil1
Novice
4,469 Views

Hello All,

Happy New Year to all

I have a Think pad that shuts down EXACTLY every 30 minutes.

Ruled out power config sleep setting, fan, heating of laptop etc.

Tried safe mode-Shutdown 30 min

Tried leaving laptop in BIOS mode-Shuts down 30 minutes.

 

Internet forums suspect Intel Management Interface / Intel Vpro causing it.

Specs,

Windows 10 Home

Core I5 Sandy Bridge platform 

South Bridge QM67 chipset

 

Any suggestions / fixes

Thanks

0 Kudos
34 Replies
JoseH_Intel
Moderator
3,478 Views

Hello Sunil1,


Thank you for joining the Intel community


The issue you describe doesn't seem to be related to the Intel Management Engine on your system. First of all you want to make sure that your system is AMT capable, otherwise there is no ME present at all. In case your computer is AMT capable but if has never been provisioned for remote management then the ME is inactive thus not causing any kind of issues. Based on your description seems plausible your computer might have overheating issues making it to shut down around 30 mins to prevent damage. In this kind of cases you want to contact the laptop manufacturer support to get the hardware troubleshot and evaluate possible warranty replacements.


Hope it helps


Regards


Jose A.

Intel Customer Support Technician


Sunil1
Novice
3,417 Views

Hello Jose,

Appreciate the quick and informative response. Thank you kindly for that.

I have ruled out Fan/Overheating as Laptop shuts down even if left in BIOS.

In regards to the AMT/ME I believe this laptop is capable due to the Core I5 vPro sticker. Now the interesting part is that I cannot find any trace of ME install in device manager under system devices.

 

This laptop was purchased second hand and I am not aware of the past history or where it was used...business or home user.

 

I enjoy troubleshooting and look forward to any responses on this well regarded forum of super nice people willing to help out.

 

Look forward to any responses

Regards

n_scott_pearson
Super User Retired Employee
3,469 Views
Jose is incorrect. There is an ME in every 6 Series PCH, regardless of whether vPro is supported or not.. This 30-minute reset is what happens when the ME is not running. This is usually the result of the firmware being corrupted. You need to reinstall this firmware.
...S
Sunil1
Novice
3,416 Views

Hello Scott,

Appreciate the quick and informative response- you are spot on with your ME diagnosis as laptop shuts down even when left in BIOS. (shutdown is instant with NO warning)

 

Any tips on where I can download this ME Firmware?

Also how do I go about installing the same- any special tools needed to flash this f/w. 

Do appreciate all the responses from the esteemed users on this forum.

I highly appreciate Jose response

Regards

S

n_scott_pearson
Super User Retired Employee
3,397 Views
Some vendors build the ME firmware into their BIOS update packages and some keep it separate. You will need to check the support page for your laptop to see what is available and how to install it.
Hope this helps,
...S
Sunil1
Novice
3,289 Views

Hello Scott,

Appreciate the response.

As advised I found an earlier version  of the Bios which updates the "ME firmware", on Lenovo's website.

That's the easy part.

However my laptop will not let me install this .

Error "Bios image does not match the system"

Tried running in comparability mode for Win 7, Win 8-no go.

Currently have Win 10 pro installed.

Any tips?

Thanks again

S

Sunil1
Novice
3,229 Views

My Laptop Issue still outstanding, Not resolved yet.

Had to post this as Intel Community admin wanted an update.

AlHill
Super User
3,226 Views

You are dealing with a device that is more than a decade old.  It is time to pass on this, take it to a recycle bin, and get a new laptop.

 

Just an opinion.

 

Doc (not an Intel employee or contractor)
[Waiting for Windows 12]

n_scott_pearson
Super User Retired Employee
3,215 Views

You need to install the BIOS update (which should be latest available, BTW) in whatever BIOS Recovery Mode Lenovo supports/supported, This is necessary to support updating the ME Firmware when the ME is not running to assist.

Since I am not very familiar with the architecture of the Lenovo BIOSs or their updates, I really can't help you with this. Hopefully Lenovo will assist (though I am not getting my hopes up considering the age of this laptop).

...S

SJack2
New Contributor II
2,360 Views

Saw this title and immediately recognised it as a ME issue.

@Sunil1 did you ever get resolved? 

Laptop is not a write-off as has been suggested - SandyBridge will chug along nicely with W10 until 2025.

Lenovo Model number (on base of laptop) would easily find the UEFI/BIOS update on the Lenovo support site and a reflash would probably fix it.

30 minutes is enough to download and install an updated ME firmware image using the FWUpdate tool from the Intel System Tools applicable to your ME version. 

Either way, the fix should be (relatively) simple.

Sunil1
Novice
2,358 Views

Hello SJack2,

Thank you  for your email, welcome to this community.

Secondly thank you for your vote of confidence to keep using Sandy
Bridge as it is chugging along much better than some others.

Now about the ME causing this- you are spot on.

 

Here is what I have tried so far....

Lenovo Model T420  Type 4178 -6UU

*I have reverted to factory image on this T420 laptop now running
windows 7 that came with it out of the factory.

**I have tried flashing EVERY (T420) supporting Bios update from the
Lenovo website starting with the Oldest Bios ver. and slowly upgrading/updating
until the Latest Bios ver. update available was installed.
Sadly none of these updates resolved anything.

Some of the Bios updates included a Intel ME FW update as well.

The laptop still runs super fast - but sadly only for the exactly 30 minutes.

Thank you again for reaching out to me.

Let me know if I have missed anything or is there another way to flash
the ME FW update.

Intel’s website does not offer any update tools for ME FW update.

Most of google searches for this issue points me to a CPU thermal
shutdown or a virus.

Really DO NOT want to scrap a good laptop.

Look forward to hearing from you.

Regards
Sunil1

SJack2
New Contributor II
2,291 Views

@Sunil1 Using the Intel System Tools is an option. I think my reply has been removed (moderated).

 

Can you post a screenshot of the output of the CSME Validation Tool for Legacy Systems?

 

Downloadable here;

 

Intel® Converged Security and Management Engine (Intel® CSME) Detection Tool for Legacy Systems

 

I will direct this via PM if the replies continue to be removed. 

Sunil1
Novice
2,271 Views

Hello SJack2,

Will do as requested in your email, and thank you for the same.

Will post CSME screenshot for your review.

Thanks again,

Regards

Sunil1

Sunil1
Novice
2,253 Views

Hello SJack2,

As promised here is the output of CSME validation tool.

Used the GUI version of the CSME tool.

PS: the link provided worked well.

 

Thank again,

Regards,

Sunil1

SJack2
New Contributor II
2,242 Views

@Sunil1 so applying first principles, the tool is unable to detect the ME state.

 

I see the laptop is still running the W7 image, please update to the W10 licence you were using before; use the upgrade tool (click the 'Update Now' button) and you should retain the W10 digital licence you were using previously. Please alert me if the Windows version you are using is 32-bit - for the most reliable and replicable environment the 64-bit version is recommended. Version can be found at the Run box, (hold [WIN] key & hit [R] key), type winver and hit OK. Advice here.

 

This will have the effect of eliminating the possibility of old drivers obfuscating the ME version.

 

For completeness' sake, before you do the update, please download the Intel SA-00086 Detection Tool (use the Major Geeks link provided below, select the second link below 'Download Now' - 'Download@MajorGeeks', the 'Download@AuthorsSite' link redirects to the CSME VDT and is not the correct tool for your system. Please post the output of the tool here.

 

Download Intel-SA-00086 Detection Tool - MajorGeeks

 

When you have the system updated to W10, please run the CSME Validation Tool for Legacy Systems again to see if the ME detection issue is resolved. 

Sunil1
Novice
2,204 Views
Sorry but Windows 10 will not install in 30 min. Laptop shuts down before install completed. BTW win 7 is 64 bit.
lfb
Novice
2,175 Views

All the bios updates Lenovo offers don't contain a configured (non- initialized) ME region but just the bios region, and the ME updates Lenovo offers contain only unconfigured update images. Since these updates are performed by the ME firmware itself they won't work if the the firmware is corrupted. So there's no help for your problem from Lenovo there. 

Try searching for "Clean Dumped Intel Engine Regions"- it's not as rare as it might look, and it's been solved before many times.

SJack2
New Contributor II
2,150 Views

OK, firstly there should be time to update the MEI driver pack. (If the installer complains you are overwriting newer files, then skip the file or cancel the installation. Reboot if prompted.)

 

https://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/83ra31ww.exe

 

Then, download and extract the following .zip file (using Windows File Compression, just double-click the file, when asked for a path to extract to select C:\). Ensure the machine is on mains power.

 

https://www.dropbox.com/s/3u0htxc9bmdft59/WIN32_7_1_92_3272.zip?dl=0

 

Open a command prompt (as Administrator) from Windows Start Menu, then type the commands in bold followed by [ENTER] key.

 

cd \ (prompt should show c:\)

cd win32 (prompt should show c:\win32)

fwupdlcl.exe -f fwupdate.bin (dialog should begin, do not interrupt, restart system when prompted)

 

Any error dialogs post back here (there may be one, but hopefully not) then when the system has restarted run the CSME Validation and Detection Tool once more. Hopefully it will be successful and the system should no longer shut down.

 

lfb
Novice
2,134 Views

I'm sorry, but:

The updates triggered via Fwupdlcl are performed by the ME firmware itself. Fwupdlcl sends the new (unconfigured) firmware parts to the ME which then itself will run the update process This way one can update the code partitions of the ME firmware but not the data partitions. But the latter are most often the part which is corrupted. 

- Normally these updates won't work if the ME is corrupted and even if they would work-

- Since they don't update the corrupt data partitions you still have a corrupted ME firmware. 

Since there's no ME interface in device manager the win32 version of Fwupdlcl probably won't work even with updated drivers. There's still a DOS version of the tool, but because of the reasons already mentioned this probably won't work either.

SJack2
New Contributor II
2,127 Views
Okay. Let’s try this way and see what happens first.
Reply