Intel® vPro™ Platform
Intel Manageability Forum (Intel® EMA, AMT, SCS & Manageability Commander)
Announcements
Intel® Endpoint Management Assistant (Intel® EMA) Cloud Start Tool for Azure* 2.0 is now available for download here.

The Intel® Manageability Commander 2.2 has been released! Learn more here.

The Intel® Endpoint Management Assistant, version 1.5.1 is now available for download here.

The Intel® Setup and Configuration Software tool will End of Life (EOL) on 12/31/2022. The Intel® Setup and Configuration Software Download will be available until March 31, 2021. For details, Please click here.
2562 Discussions

RCS Server Service Crash & Restart

SysArch
New Contributor I
616 Views

Hello

We are having two enviroments using SCS Console and therefore running the RCS Server Service

Production - Version 12.2.0.139, Test - Version 12.2.0.150 both running as NetworkService

However within the last two months the Service got pretty unstable in both environments. Resulting in a crasch of RCSServer.exe with an automatic restart almost every minute. The RCS Logs shows some "AMT Interface error" from Enddevices and then just stops.

Pretty much the same Scenario as here https://community.intel.com/t5/Intel-vPro-Platform/RCSServer-service-starts-but-stops-within-a-minut...

Just that I deleted all Jobs on Test and this is still happening.

However there are Devices Working which can get their Configuration. But one that is Working and one with an Issue seem to be identical (Same ACU Version 12.2.0.139, Config ect.) And even some of the issue Devices seem to have worked once, since they have an AD Object. (Deleting this, does not help)

Please find attached a Log from the RCS Server Log.

Any ideas what this is causing?

Best Regards, Andy

 

 

0 Kudos
6 Replies
JoseH_Intel
Moderator
602 Views

Hello SysArch,


Thank you for joining the community


From your description I can think you have the SCS integrated with Active Directory and running in Database mode. You stated to have deleted all queued jobs. Are they actually deleted completely? Could it be any remaining job not possible to be deleted for any reason?

The reason that both environments with different versions are getting unstable makes me think there is something external conflicting and making the RCSserver service to crash continually. 

Could you please tell what version of AD you have currently installed and if there has been any recent update been held?


I will look forward for your updates


Jose A.

Intel Customer Support Technician


SysArch
New Contributor I
594 Views

Hello Jose,

Correct we are running Database Mode connected with our integrated AD. 

The jobs where gone completely in the RCS, don't know where to check else. If this helps we are using a Maintenance Job to reset the Password and an Automatic Maintenance one to reissue the certificate.

In my opinion this has something to do with the "broken" clients either on Client Side or with AD synchronisation. If I have a client with an issue, I can reproduce the error when running acuconfig again.

C:\Program Files (x86)\Intel\SCS ACUConfig\ACUConfig.exe /KeepLogFile /Output File C:\sysmgt\log\Set-IntelAmtConfiguration.logexe ConfigViaRCSonly rcsserver.mydomain.local DefaultProfile /RCSBusyRetryCount 3

AD Domain & Forest Level is 2012 R2 with no recent changes. The changes I see are the Updates to 12.2.0.139 in July 2020 and 12.2.0.150 in October 2020 as well as an increase in deployed clients.

Best regards,
Andy

 

JoseH_Intel
Moderator
587 Views

Hello SysArch,


Thank you for all this new updates provided. I will research on this and will contact our senior team, but their reply will be a bit delayed because of the holidays. I will let you know as soon as I have news.


Regards


Jose A.

Intel Customer Support Technician


JoseH_Intel
Moderator
584 Views

Hello SysArch,


Could you please tell when did the issues started?

Besides that please send logs from “C:\ProgramData\Intel_Corporation\RCSConfServer” folder for both SCS servers. Zip up all content from folder.


We'll look forward for you updates


Jose A.

Intel Customer Support Technician


SysArch
New Contributor I
580 Views

Hello Jose,

 

Thank you for your help.

In my opinion the Issue started with installation of the 12.2.0.139 Version back in July 2020. However we did not have a lot of Clients then and other issues we focused on. We did rollout quite some devices in the last two months and I think the issue was better noticed since then.

I am happy to share the logs with you, but only in private. I cannot share them publicly. Where can I send you them?

Best regards,

Andy

JoseH_Intel
Moderator
570 Views

Hello SysArch,


I just sent you an email to your personal address. You can reply back with the requested logs. No information will be published that way.


Regards


Jose A.

Intel Customer Support Technician



Reply