Intel vPro® Platform
Intel Manageability Forum (Intel® EMA, AMT, SCS & Manageability Commander)
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
2616 Discussions

RealVNC Plus keeps disconnecting after 1min of idle

Community Manager

Problem is here I want it to stop doing this. Ive got the DQ67EP board with the i7 2600 processor. I updated Bios to the latest 0054 revision which changed the IntelME settings alot compared to all the intel AMT setup documents. Its now all inside the Bios, no separate F2 to get into IntelME.

Now going into all the Intel ME settings there is only one setting for a time called Intel ME Timeout, it was 1, I changed it to 1440 (takes a value as high as 65535 I believe).

Rebooted, tried RealVNC, still after 1min it disconnects.

Then googled around and shows go to the Expert Tab on RealVNC and change the "AmtSessionTimeout". Well it was already set to "-1" which says it follows what the Intel AMT setting is (which i think is 1440 now). Still disconnects after 1min. Changed that AmtSessionTimeout to 255 (highest allowed in RealVNC). Still disconnects in 1min. Changed it to 0 which says never disconnect, still disconnects after 1min of idle.

What am I doing wrong? Its pretty annoying that every 1min it disconnects of no use. I need more time then 1min idle.



0 Kudos
2 Replies

As you may have guessed, the KVM timeout value is not settable via MEBx / BIOS.

RealVNC should be able to set these. I'm not sure why it didn't work when you set AmtSessionTimeout to 0.

Try this: download and install Manageability Commander from

Then you can add your DQ67EP by it's IP, enter credentials, and connect. Under the remote control tab, click the * next to KVM Remote Control settings. Here you can adjust the TCP Session Timeout. When you click OK, the settings are saved into AMT. Now, try RealVNC again. Hopefully it will not timeout. Let me know how it goes.

Community Manager

Thanks for the info. Im not exactly sure what fixed it. But I also ended up updating the Bios to 0055 (which I noticed just showed up for this board). I initially looked 1week ago, but looks like this Bios is brand new, just a few days old. So I flashed the new one, loaded defaults, and reconfigured the Bios to my liking.

Then I also installed that toolkit and set the Remote Control options as you said, except the timeout was already 0, so I set it to 1, and then back to 0 to make sure.

Now RealVNC been going to at least 30mins without that window in the foreground, its in the background and still there and not disconnected.

Thanks again!