Media (Intel® Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools like Intel® oneAPI Video Processing Library and Intel® Media SDK
Announcements
The Intel Media SDK project is no longer active. For continued support and access to new features, Intel Media SDK users are encouraged to read the transition guide on upgrading from Intel® Media SDK to Intel® Video Processing Library (VPL), and to move to VPL as soon as possible.
For more information, see the VPL website.
3056 Discussions

MSS2017 install_sdk_CentOS.sh fails because of kernel(dma_buf_attach)

huihai_l_
Beginner
344 Views

Hi,

I have just done a fresh install of the latest CentOS 7 CentOS-7-x86_64-Everything-1611.iso.

I downloaded the MediaServerStudioEssentials2017.tar.gz, and executed MediaServerStudioEssentials2017/SDK2017Production16.5/CentOS/install_sdk_CentOS.sh with sudo.

But the script complains the failed dependencies when installing kmod-ukmd rpm with the following message:

Installing kmod-ukmd-16.5-55964...
error: Failed dependencies:
	kernel(dma_buf_attach) = 0xfa625ae7 is needed by kmod-ukmd-16.5-55964.el7.x86_64
	kernel(dma_buf_detach) = 0x96af1fbc is needed by kmod-ukmd-16.5-55964.el7.x86_64
	kernel(dma_buf_export) = 0xc29ffda2 is needed by kmod-ukmd-16.5-55964.el7.x86_64
	kernel(dma_buf_fd) = 0x839654d1 is needed by kmod-ukmd-16.5-55964.el7.x86_64
	kernel(dma_buf_get) = 0x3d69c155 is needed by kmod-ukmd-16.5-55964.el7.x86_64
	kernel(dma_buf_map_attachment) = 0xb82925d1 is needed by kmod-ukmd-16.5-55964.el7.x86_64
	kernel(dma_buf_put) = 0xf7ec7b43 is needed by kmod-ukmd-16.5-55964.el7.x86_64
	kernel(dma_buf_unmap_attachment) = 0xdfd6347f is needed by kmod-ukmd-16.5-55964.el7.x86_64
	kernel(fput) = 0x76bcc79d is needed by kmod-ukmd-16.5-55964.el7.x86_64
	kernel(i2c_new_device) = 0x62f8040e is needed by kmod-ukmd-16.5-55964.el7.x86_64
	kernel(i2c_transfer) = 0x5e7d6573 is needed by kmod-ukmd-16.5-55964.el7.x86_64
	kernel(i2c_unregister_device) = 0x609ae14e is needed by kmod-ukmd-16.5-55964.el7.x86_64
	kernel(perf_tp_event) = 0x66a49d27 is needed by kmod-ukmd-16.5-55964.el7.x86_64
Installation done.

Does anyone know how to solve it? Thanks!

0 Kudos
1 Reply
Deschamps__Fabien
344 Views

Hi Huihai,

I'am actually facing the same issue. Did you found the answer ?

Regards,

F.Deschamps

 

0 Kudos
Reply