Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12622 Discussions

How to resolve the error 'modelsim (vsim) is not on the path'?

ZikunTan
Beginner
5,106 Views

Hi!

 

I am initializing Intel HLS compiler according to the instruction. I have downloaded Quartus, Visual Studio and Modelsim.

 

What I typed 'C:\intelFPGA\18.1\hls\init_hls' in command prompt and press 'Enter', it says that 'Modelsim (vsim) is not on the path'. What's wrong with it? How can I resolve this error to initialize HLS compiler?

 

The error screenshot is shown below.

 

Thanks.Capture.PNG

0 Kudos
3 Replies
MuhammadAr_U_Intel
3,836 Views

Hi,

 

Vsim is looking for Modelsim executable path.

 

Make sure you have any version of Modelsim installed in your system and the executable path is added to windows environment variable "PATH"

 

Once Modelsim executable path is added, close, re-open command prompt and try executing the .bat script again to initialize.

 

thanks,

Arslan

0 Kudos
Abe
Valued Contributor II
3,836 Views

Capture.JPGClick the Start button and type Control, in the list of search items , select Control Panel and then System and Security. Then select View amount of RAM and Processor Speed under System . Next click the Advanced System Settings option in the left pane.

 

In the window that opens, click the Environment Variables option and select the Path option to highlight it. Now, click the Edit... button.

 

In the window that opens up, make sure to enter the Quartus and ModelSim installation path as shown in the screenshot. Then click Ok to close the windows, and then finally open the Command Prompt and try again.

 

0 Kudos
ZikunTan
Beginner
3,836 Views

Yes, this problem was caused by my wrong environment setting of ModelSim. I have corrected my path and now it is going well. Thanks for your response.

0 Kudos
Reply