Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12626 Discussions

How to update my project in eclipse when i add a component in design

homeinit
Novice
1,465 Views

Dear Intel community hello,

 

I am using the USB blaster to download my SOC Nios ii, Quartus (Quartus Prime 17.1) Lite Edition, windows 10, Cyclone iv FPGA  EP4CE6F17C8.

I downloaded the Nios 2 and started the project on Eclipse, it compiles and runs.

I want to update my project to pass the fast version of Nios with breakpoints.

After that, I regenerated the BSP and the project on Eclipse and compiled the project.

When I want to run the project the second time, I have this message, "connected system id hash not found on target at expected base address." 

In the Target connection check the boxes ignore mismatch id and mismatch time stamp. 

but still could not run the project.

If I tick the boxes in the Run As Configuration that make Nios ignore the ID and timestamp values from the sys id, I get an error saying "Downloading ELF process failed". I think there must be something wrong with the communication with the board, but can't figure out what it is.

 

Could you help please me understand why? If I want to use the NIOS/f version, do I have to buy a license?

If yes, does the student license exist? I am a student how I could debug my project and add breakpoints to my code?

Do I have to add a PLL to multiply (x2) the clock If you want to debug the project?

There is a message in Qsys.  (Info: NiosFreeRTOS.jtag_uart_0: JTAG UART IP input clock need to be at least double (2x) the operating frequency of JTAG TCK on board)

 

Thank you in advance.

 

 

0 Kudos
1 Solution
homeinit
Novice
1,404 Views

I think we have to leave this popup open,

homeinit_0-1681299300757.png

 

the second thing is that I installed a license I am not sure that it was a license issue but it works now!

 

View solution in original post

0 Kudos
8 Replies
EBERLAZARE_I_Intel
1,443 Views

Hi,


Do you have the screenshot of the error, I would like to see it.


Let me check on my side, regarding the error.


0 Kudos
homeinit
Novice
1,431 Views

Yes, I could share some of the pictures...

homeinit_0-1681209279655.pnghomeinit_1-1681209310661.pnghomeinit_3-1681209413066.png

homeinit_4-1681209467414.png

homeinit_5-1681209486915.png

 

 

 

0 Kudos
homeinit
Novice
1,411 Views

Hello,

anything about this question, please?

0 Kudos
homeinit
Novice
1,405 Views

I think we have to leave this popup open,

homeinit_0-1681299300757.png

 

the second thing is that I installed a license I am not sure that it was a license issue but it works now!

 

0 Kudos
EBERLAZARE_I_Intel
1,387 Views

Hi,


I am tied up on my side, I am still looking into your issue, do you mean that you close the Quartus programmer after hitting 100%? Then it hits the error?


or If you keep it open, (despite having it 100%) you will not get the error? Is this correct?


0 Kudos
EBERLAZARE_I_Intel
1,359 Views

Hi,


Do you still need help on this issue?


0 Kudos
homeinit
Novice
1,341 Views
0 Kudos
EBERLAZARE_I_Intel
1,321 Views

Hi,


I’m glad that your question has been addressed, I now transition this thread to community support. If you have a new question, Please login to ‘https://supporttickets.intel.com’, view details of the desire request, and post a feed/response within the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you on your follow-up questions.



p/s: If any answer from the community or Intel Support are helpful, please feel free to give best answer , or you may select your own or rate 4/5 survey.


0 Kudos
Reply