Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12603 Discussions

Issues while burning code on NIOS II Development kit

NIOS2User
Beginner
806 Views
I tried to burn a Verilog code on NIOS II development kit (EP2C35F672C6N). Here in Quartus software, it is showing the FPGA programmed successfully, but the default program is running on the kit, and the factory conf light is on. What do you think I should do to make it behaves like I programmed?
0 Kudos
6 Replies
KellyJialin_Goh
Employee
792 Views

Hi,

Welcome to Intel's forum.

I am glad you have successfully programmed your FPGA with the .v file you have but to indicate whether it is programmed like what you mentioned, you may go back to your project file directory, under the output file, check and see whether a .sof file is generated or not. But given your statement, I believe the .sof file is already in your output file directory and meaning it is successfully programmed to your FPGA.


Hope this could clear your doubts.


Thank you.

Regards,

Kelly





0 Kudos
KellyJialin_Goh
Employee
750 Views

Hi,

Any updates on whether the information provided is useful and has solved your issue?

Looking forward to your updates. Thank you.


Regards,

Kelly


0 Kudos
CYCLONE2USER
Beginner
709 Views
Hello Kelly,
I (NIOS2User) am unable to post with my previous account due to some issues in it and therefore I am posting with my other account.

I tried again to burn the code based on your provided information but still it is running the default program only with the conf light on.

Looking forward for your reply.

Thank you
0 Kudos
KellyJialin_Goh
Employee
697 Views

Hi,

The default code might be running instead of your verilog code. You may need to remove the default code .c file and replace it with just your coding file.


Another issue might also be related to your flashing methods of the code. May I know which flashing/booting methods have you used to program your Cyclone II?

Here is a reference for you to have a look on the correct booting methods for your project: https://www.intel.com/content/www/us/en/docs/programmable/683820/current/nios-ii-processor-booting-methods.html


Hope to hear on your findings.

Thank you.


Regards,

Kelly


0 Kudos
KellyJialin_Goh
Employee
654 Views

Hi,

Any updates from your side on deleting the default code and only enable your coding file.

Have you also checked out on the booting methods as the issue might also rely on when your are programming your .sof/.jic file into your Cyclone II.


Hope to hear from you soon.

Thank you.


Regards,

Kelly


0 Kudos
KellyJialin_Goh
Employee
624 Views

Hi,

As we do not receive any response from you on the previous question/reply/answer that we have provided. Please login to ‘https://supporttickets.intel.com’, view details of the desire request, and post a feed/response within the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you on your follow-up questions.


p/s: If any answer from the community or Intel Support are helpful, please feel free to give best answer or rate 4/5 survey.


Thank you.

Regards,

Kelly



0 Kudos
Reply