Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12595 Discussions

Migrating from EPCS to EPCQ-A nios fails to boot after flash

CDai0
Novice
553 Views

I have a legacy project using a Cyclone 2 that we would like to migrate from the obsolete EPCS to same size EPCQ-A. following the migration app note, it appears we don't need a FPGA rebuild since we are using Serial Flash Controller IP is compatible when disabled sector protect and the size is <128M

https://www.intel.com/content/www/us/en/docs/programmable/683340/current/ip-core-and-programming-file-migration.html

However, we were using the nios2-flash-programmer command line with a .flash file and this tool throws the following error with the new flash part: (verified works with old EPCS device)

Using cable "USB-Blaster [USB-0]", device 1, instance 0x00
Resetting and pausing target processor:
OK
No EPCS layout data - looking for section [EPCS-EF4015]
Unable to use EPCS device
Leaving target processor paused

 

Next, I try to generate a .jic file format following steps in this forum: https://community.intel.com/t5/Nios-V-II-Embedded-Design-Suite/No-EPCS-Layout-data-looking-for-section-EPCS-C84017/td-p/169751?profile.language=ko

However, although the Quartus programmer successfully program and verifies the .jic file, the Nios is not starting. The FPGA is configured since it can be detected in nios2-terminal and I can download the .elf code through JTAG.  The issue is for some reason on startup its not running the flashed nios code. Please advise.

0 Kudos
1 Solution
CDai0
Novice
494 Views

I got it working by recompile everything with a newer version of Quartus (13.0sp1). Earlier I was just trying to regenerate programming files without rebuilding, using the sof and elf someone previously compiled.  The comments in the build say it was previously compiled with Quartus 11 and but I suspect the Qsys was generated in an even older version since when I opened it did the sopcbuilder to Qsys upgrade.

View solution in original post

0 Kudos
3 Replies
wwanalim_intel
Employee
528 Views

Hi,

 

Greetings and welcome to Intel's forum.

Please give me some time to check on this issue and will get back to you with the update.

 

Thank you.

Regards,

Fathulnaim


0 Kudos
CDai0
Novice
495 Views

I got it working by recompile everything with a newer version of Quartus (13.0sp1). Earlier I was just trying to regenerate programming files without rebuilding, using the sof and elf someone previously compiled.  The comments in the build say it was previously compiled with Quartus 11 and but I suspect the Qsys was generated in an even older version since when I opened it did the sopcbuilder to Qsys upgrade.

0 Kudos
wwanalim_intel
Employee
479 Views

I’m glad that your question has been addressed, I now transition this thread to community support. If you have a new question, Please login to ‘https://supporttickets.intel.com’, view details of the desire request, and post a feed/response within the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you on your follow-up questions.


0 Kudos
Reply