Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12612 Discussions

ModelSim Altera bug in Create Pattern Wizard

Altera_Forum
Honored Contributor II
1,078 Views

I'm trying to use the pattern wizard on modelsim to simulate a simple flip-flop d that i wrote in verilog, i'm following the tutorial on altera.com/literature/ug/ug_gs_msa_qii.pdf and when i click in Edit -> Create/Modify Waveform the window appear but when i hit next suddenly the window shrinks and i can't do nothing to bring it to normal, see these pictures: 

 

dropbox.com/s/ru4m1aj4m031y3x/ms_altera_bug1.png 

 

and when i hit next: 

 

dropbox.com/s/65hq4wkjpw1bwxc/ms_altera_bug_2.png 

 

I know that the better way to do this is writing an test bench for it, but for now i want to keep it as simple as possible, it is a ff d. 

 

It seems to me that this is a bug, caused by some library that i have and don't know each one it is. By the way i'm running it under Ubuntu 12.04.1 LTS and the version of ModelSim is 10.1b for quartus 12.1
0 Kudos
4 Replies
Altera_Forum
Honored Contributor II
388 Views

Hi, 

 

I have the same problem, did you get any solution since you wrote this post? 

 

 

 

 

--- Quote Start ---  

I'm trying to use the pattern wizard on modelsim to simulate a simple flip-flop d that i wrote in verilog, i'm following the tutorial on altera.com/literature/ug/ug_gs_msa_qii.pdf and when i click in Edit -> Create/Modify Waveform the window appear but when i hit next suddenly the window shrinks and i can't do nothing to bring it to normal, see these pictures: 

 

dropbox.com/s/ru4m1aj4m031y3x/ms_altera_bug1.png 

 

and when i hit next: 

 

dropbox.com/s/65hq4wkjpw1bwxc/ms_altera_bug_2.png 

 

I know that the better way to do this is writing an test bench for it, but for now i want to keep it as simple as possible, it is a ff d. 

 

It seems to me that this is a bug, caused by some library that i have and don't know each one it is. By the way i'm running it under Ubuntu 12.04.1 LTS and the version of ModelSim is 10.1b for quartus 12.1 

--- Quote End ---  

0 Kudos
Altera_Forum
Honored Contributor II
388 Views

Sadly I couldn't work with the "Pattern Wizard" in MultiSim, I finally opted to work with TestBenches, the graphical aproach didn't get me anywhere. 

 

I think that I try it in windows XP, and if my memory isn't wrong, it happened the same problem, but it's worth an try. 

 

 

--- Quote Start ---  

Hi, 

 

I have the same problem, did you get any solution since you wrote this post? 

--- Quote End ---  

0 Kudos
Altera_Forum
Honored Contributor II
388 Views

Ok, Thank you for your fast reply.

0 Kudos
Altera_Forum
Honored Contributor II
388 Views

Has anyone found a solution for this problem? I would very much like to use the Pattern Wizard.  

 

I'm using Ubuntu 12.04. Has anyone had success with this feature in more recent editions?
0 Kudos
Reply