Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12620 Discussions

Simple socket server example ---> unable to find working interfaces

Honored Contributor II



I started working with Altera Stratix 4 GX development board recently. I am trying to run the simple socket server example (nios 2 ethernet standard example -  


Reading from other posts I was able to build and compile it with static IP. I changed the BSP to disable DHCP. When I run it on the board, it seems not to recognize the Ethernet interface.  


It says:  

prepped 0 interfaces, initializing... 

inet setup error: unable to find any working interfaces 

panic: IP 

dtrap - needs breakpoint 


Can anyone give a hint to where should I look to debug this? Or what should I do? 


Thank You, 


0 Kudos
1 Reply
Honored Contributor II

Hi all, 


I found that Altera no longer supports the NicheStack TCP/IP Stack - Nios II Edition. 


Is there any other alternative to buying the license?  


If someone else faced the same problem as me and solved it.. let me know.
0 Kudos