Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12618 Discussions

U-boot: USB device communication problems on cycloneV (dwc2)

Honored Contributor II



I have a CycloneV SoC Development kit, rev D. The builder machine is a Debian 8.5, 64 bit, using Yocto/Poky. 


I would like to boot the kernel from an external USB mass storage device. Now i have a u-boot 2013.01.01 build and it can boot from a pendrive correctly. 

My goal would be to use another Linux box to provide these files using cdc mass storage emulation. If i connect it to my board, the device is not detected at all. If it is connected through a USB HUB, then it is detected, but the communication fails. After some debugging i found that the nak messages are not handled in the dwc2 driver (see drivers/usb/host/dwc2_otg-hcd.c). 


I tried to build the v2016.05 tag because i see that its dwc2 driver has a lot of changes and hopefully works better. I could not find any existing recipe to build it, so i tried to modify my existing one. 

I changed the followings: 


UBOOT_REPO = "git://" UBOOT_PROT = "https" UBOOT_BRANCH = "master" UBOOT_TAG = "aeaec0e682f45b9e0c62c522fafea353931f73ed" 


and the compilation rule: 


do_compile () { unset LDFLAGS unset CFLAGS unset CPPFLAGS cp my_config .config oe_runmake } 


Everyting is compiled correcly, but the linker phase is failed: 


arm-poky-linux-gnueabi-ld.bfd: error: required section '.rel.plt' not found in the linker script arm-poky-linux-gnueabi-ld.bfd: final link failed: Invalid operation 


I found this error message on the net, but the answers were not suitable for me. 


Can anyone help me to build it, or to fix the USB communication problem? 


Thanx in advance 

Gyorgy Kovesdi
0 Kudos
0 Replies