Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12618 Discussions

fatal error - cygheap base mismatch detected ... cygwin1.dll...NiosII/Eclipse problem

Honored Contributor II

I'm trying to build and run a simple NiosII system on my DE2-115 board. I'm using Quartus II 64-bit version 14.0.0 Build 200 06/17/2014 SJ Full Version, and the corresponding Qsys and Nios II Software Build Tools for Eclipse version  

I found this Youtube tutorial, . I went through all the steps, and everything worked until the final step. (I.e. the building of the SOPC core in Qsys worked fine, and setting the pins & compiling the project in Quartus worked fine, and programming that core onto the DE2-115 worked fine, and the target system ID matched the expected value, and the compiling/building of the simple C program in NiosII Eclipse worked fine, but the part that didn't work was the programming of the compiled/built .elf file into the DE2-115 board.) The author of the video also had the same problem at the end of the video, and he said it was because he hadn't installed Cygwin. 

This is the error I get in the console (after the little dialog box popped up saying "Downloading ELF Process failed"):  

0 [main] nios2-gdb-server (91992) c:\altera\14.0\nios2eds\bin\nios2-gdb-server.exe: *** fatal error - cygheap base mismatch detected - 0x612708d0/0x7f08d0. 

this problem is probably due to using incompatible versions of the cygwin dll. 

search for cygwin1.dll using the windows start->find/search facility 

and delete all but the most recent version. the most recent version *should* 

reside in x:\cygwin\bin, where 'x' is the drive on which you have 

installed the cygwin distribution. rebooting is also suggested if you 

are unable to find another cygwin dll. 

/cygdrive/c/altera/14.0/nios2eds/bin/nios2-download: line 609: 71760 segmentation fault nios2-gdb-server --cable 'usb-blaster on localhost [usb-0]' --device 1 --instance 0 --sidp 0x11010 --id 0x1234 --timestamp 1415253604 --reset-target --go --tcpport none --write-pid /cygdrive/remainderofpathhere/sopctest_nov5_2014_1/software/qsys_test_nov5_2014_1/ m:/remainderofpathhere/sopctest_nov5_2014_1/software/qsys_test_nov5_2014_1/qsys_test_nov5_2014_1.elf.srec  

I searched my hard drive for other Cygwin installations. There was one other one in a different directory. I tried renaming all cygwin1.dll files to cygwin1_old.dll, but this had no effect on the NiosII/Eclipse programming error shown above. I also tried downloading a fresh cygwin install and replacing the Quartus/Eclipse version with the new version, but this produced a different error and didn't solve the above problem.Can anyone suggest a way to solve this problem, or point me toward a resource? Thanks in advance.
0 Kudos
1 Reply
Honored Contributor II
0 Kudos