Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12627 Discussions

issues with running project in quartus


I am new to using fpga and was trying to run the project: 

I tried running the project in Quartus versions 17.0, 17.1, 18.0, and 20.0 on Linux (ubuntu) and windows. In all these I got the same error message:

Error: nios_setup.crc_0: Component crc 1.0 not found or could not be instantiated


I tried using auto IP upgrade but got error in that. 

Can someone help me with how to solve this?

0 Kudos
3 Replies



I guess you're using the design from this link:

The error is due to Altera CRC Compiler Megafunction missing. This Megafunction only exists until Quartus II 13.0.

The latest version for that design is Quartus II 16.0. And I'm able to compile the design with Quartus II 16.0 check image.


Even though Quartus II 16.0 don't have that Megafunction as well but will not issue error because it don't need the ip upgrade. Also, compiler straight away using the CRC submodules in ..\nios_setup\synthesis\submodules folder when nios_setup.qip is included. So it's good to go with Quartus II 16.0. This Quartus version can't be downloaded anymore so probably have to raise ticket in Intel Premier Support for version request.


Best Regards,


p/s: If any answer from the community or Intel Support are helpful, please feel free to give best answer or rate 4/5 survey.


0 Kudos

Thanks for replying we will raise a ticket on Intel Premier Support and will get back to you if faced with any other issue.

0 Kudos

Hi Sheng


We have received Quartus Prime Lite v16.0 and tried the project on it and as you mentioned it does not require a ip upgrade. But the qsys file still show the error:

Error: nios_setup.crc_0: Component crc 1.0 not found or could not be instantiated

But I am assuming it will be shown but the project will directly fetch the .qip file and compile properly.


We are facing a different issue and were hoping you assistance, we are following the instructions from the guild:

And in that document under "Steps to Run the Program", step 3. (v). ask to select the "Verify" checkbox in the Programmer window but in our project we are not able to do that.

Also can you tell us what are we expecting in the output on Nios II command shell

0 Kudos