OpenCL* for CPU
Ask questions and share information on Intel® SDK for OpenCL™ Applications and OpenCL™ implementations for Intel® CPU
Announcements
This forum covers OpenCL* for CPU only. OpenCL* for GPU questions can be asked in the GPU Compute Software forum. Intel® FPGA SDK for OpenCL™ questions can be ask in the FPGA Intel® High Level Design forum.
1663 Discussions

Braswell iGPU OpenCL Inconsistencies[Solved]

Huseyin_Tugrul_B_
425 Views

 

Hi, I just  bought an Acer(packard bell) laptop that has a N3060 SoC. According to Intel, Wiki and Notebookcheck sites, it must have 8. Generation HD graphics 400(not 4000) of Braswell architecture with 12 compute units @ 320-600 MHz.

It is working under windows-10 64 bit home edition(single language) build 10240, 4GB single-channel RAM.

I'm also developing opencl programs on another machine and wanted to migrate them to this machine.

Before that, I tested against if opencl is supported or not.

Observation:

  • compubench benchmark and any other opencl program sees it as a 8 compute units @200MHz constant frequency.
  • compubench also gives only half of benchmark points of N3050-igpu for this N3060-igpu. (igpu vs igpu, not others)
  • gpu-z shows it is stuck at 320MHz even under heavy graphics load.
  • gpu-z render test starts heavily stuttered and freezes after 10 seconds
  • OpenCL SDK for Intel says "opencl driver out of date" on installing phase.
  • No OpenCL load  increases cpu temperature(according to core temp software) but it should increase since half of chip is a gpu isn't it? Especially the t-rex part of compubench should increase temperature but not happening.
  • It writes Intel HD Graphics everywhere in computer, drivers, but not Intel HD Graphics 400.
  • It seems I'm first person to do a benchmark on compubench with an N3060 CPU(its iGPU actually).
  • AIDA64 GPGPU gives errors. 

 

What I tried to solve:

  • unsinstalling current drivers(add/remove programs-->uninstall, device manager--> uninstall) before each new install
  • installing latest drivers: n-series 15.40 which installs 10.18 for igpu and xx.xx for audio.
  • running Intel driver updater software(which scans and offers same driver above, 15.40 which installs same 10.18 for igpu). 64 bit version of course.
  • changed power saving to "performance mode" from both Intel HD Graphics settings and windows power savings settings
  • Checked an AMD gpu on compubench and it shows different frequencies as a frequency range instead of single idle frequency so I'm sure it isn't an opencl-side issue. It should be Acer-side ır Intel-side issue but I'm not sure. Also gpu-z shows that amd card having a boost to a higher frequency.


I suspect:

  • Acer(packard bell)'s support page is not active, maybe they temporarily deactivated 4 compute units and disabled dynamic frequency. But why didn't write "gimped igpu version" on computer board? I bought this computer because I need 12 compute units @320-600 MHz performance level but there is no info about that in laptop specs datasheet. 
  • Latest Intel Driver(15.40---->installs 10.18 for this n-series igpu (should be Intel HD Graphics 400, not 4000 to alleviate ofuscation) ) has bugs so need to wait next driver update.
  • I just bought this laptop so It will update to w10 anniversary and more versions, probably will include a fix for this?
  • It is single-channel RAM, so GPU is auto tuned to stay at base/idle instead of upping to boost and with only 8 compute units?

Thank you for your time.

0 Kudos
1 Solution
Huseyin_Tugrul_B_
425 Views

http://www.packardbell.com/ support page for this product is online now, installing that zipped driver.

 

Now it is working fine. It is WHQL 20.19.15.4352.

 

12 compute units at boost speed and no problems.

View solution in original post

4 Replies
Huseyin_Tugrul_B_
425 Views

Problem solved! But not with this. Check last post.

I stumbled upon a "developer" version of 15.40. Then it installed 20.19.15.4501 for igpu. Now everyything works at rated performance and hardware. It is seen as HD400 from opencl. It did not have "n-series" in its description but it had "braswell compatible" and laptop doesn't have a secondary gpu to create another problem so I didn't hesitate to install this.

 

Disabled windows-10 auto driver update.

restarted

uninstalled drivers from device manager

restarted

downloaded and installed this driver using "i have disk" option and pointing the folder in zip contents(unzipped to a folder)

restarted

compubench scores more than doubled, now I'm migrating project and adding node-js support for my wrapper instead of just tcp-ip  :()

 

Huseyin_Tugrul_B_
425 Views

Also it doesn't get that hot which is a plus.

Huseyin_Tugrul_B_
425 Views

Windows 10 forcefully updated graphics drivers even though I disabled it.

 

Now its back to 8 compute units @ 320MHz again. 

Huseyin_Tugrul_B_
426 Views

http://www.packardbell.com/ support page for this product is online now, installing that zipped driver.

 

Now it is working fine. It is WHQL 20.19.15.4352.

 

12 compute units at boost speed and no problems.

Reply