Processors
Processors (Intel® Core™, Intel® Xeon®, etc); processor utilities and programs (Intel® Processor Identification Utility, Intel® Extreme Tuning Utility, Intel® Easy Streaming Wizard, etc.)
12177 Discussions

Can not boot from USB ('Reboot and Select proper Boot device')

EHejy
Beginner
1,744 Views

Hello,

I just bought a new Mini PC and want to install an OS on it. It has already and old Windows 10 version on it, but I want to change it. Not sure in which subforum should I post. I have an Intel CPU and I think the mainboard is also from Intel.

Sadly I can not boot from USB stick. I booted many times with a USB stick before, so I know how to do it. But this BIOS seems to be very different. Also it says 'Evaluation Copy', perhaps that's the problem?

Basically the problem is the secure boot. When I activate secure boot, then the computer loads normally from hard disk and loads Windows 10. But it can not recognize any USB stick. So I have to deactivate secure boot. The USB drive is not recognized, but whenever I boot, I always get the same error message. First I can chose if I want to load from hard disk or from USB, but in both cases the computer instantly displays: 'Reboot and Select proper Boot device'.

With secure boot there is not USB stick recognized. Without secure boot the computer does not boot at all.

I asked the manufacturer but sadly they could not help me and gave me very general advise.

I would be very glad if somebody could help me, otherwise I can not use this computer.

Thank you!

Here is the error message, some photos of the BIOS and the Speccy information about my computer: https://drive.google.com/drive/folders/1QMiDzoRG1rqxYvIfF4bZl8S_v5_LPAH2?usp=sharing Can not boot from USB drive - Google Drive

0 Kudos
3 Replies
AlHill
Super User
357 Views

This is not an intel product. Contact the manufacturer of this "Mimi PC" for assistance.

Doc

n_scott_pearson
Super User Retired Employee
357 Views

That said, here's a possibility: The PC's BIOS may only have support for UEFI boot; it may not have support for Legacy boot. This means that you need to use (prepare) proper UEFI-bootable media.

Hope this helps,

...S

EHejy
Beginner
357 Views

I think you are right, there is some kind of booting issue. I could solve the problem by trying different boot loader apps.

With Rufus almost no distribution works. There are always other issues. Sometimes it does not load and the screen stays black, sometimes the USB stick is not accessed at all, sometimes it loads, but has an error message later on.

I could boot Puppy Linux with a Rufus made USB stick. And from Puppy I could create other USB boot sticks that were all working.

Usually Rufus works properly, but with this BIOS I had not luck, although I tried so many different settings in Rufus.

Thank you for the help!

Reply