Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Xrijsj
Beginner
520 Views

HDMI stopped detect 4k resolution (i7 10875H laptop)

Hello,

I have Zephyrus S17 laptop since 01/07, until yesterday I used the HDMI port with my 4K TV. and everything was ok.

 

but since 23-25/08 my HDMI is not detect 4K resolution, "no signal" on TV.

but TV is detected in display settings

and in nvidia control panel.

 

if I change to FHD resolution it's working.

 

I noticed that some Intel display driver installed in this date:

 

but I tried to uninstall this driver, I tried different HDMI cables, I tried other TV's, and I reset the windows 10 to version 1909. nothing help.

right now I send the laptop to RMA, so I didn't had the chance to take logs.

but any idea what this problem can be?

software / hardware?

https://youtu.be/aDYY8ygOwas

https://youtu.be/7-jbSyOjLC0

 

the laptop have as well thunderbolt 3 and DisplayPort, and they working normal with FHD and 4K. so it's only with the HDMI port.

0 Kudos
9 Replies
Maria_R_Intel
Moderator
495 Views

Hello Xrijsj,


Thank you for posting on the Intel* Community Forums.


I was checking your case and we usually need more information about the system to be able to determine if the issue is with the hardware or software and provide you with a complete diagnostic.


As per all the troubleshooting you performed, a hardware failure is possible. Regarding the driver, the version 26.20.100.7985 is generic.


The best thing to do is using the drivers that are provided by the system manufacturer to eliminate the potential impact caused by loading non-customized drivers (Intel's generic drivers that were not tested on your specific system). The system manufacturers regularly customize Intel generic drivers to meet the needs of their specific system design. In such cases, the use of the Intel generic driver update is not recommended.


Please, contact the Asus* support to address your query and receive more detailed support.


Best regards,

Maria R.

Intel Customer Support Technician


Xrijsj
Beginner
478 Views

Hello Maria,
Asus RMA returned to me the laptop, they said they fix it. but they didn't checked with 4K monitor.

so for now the laptop with me, until they take the laptop again.

can you tell me please which logs I need to send?
so I can send you the logs today, I will have the laptop for the weekend.
Maria_R_Intel
Moderator
469 Views

Hello Xrijsj,


Please, provide us the below details:


  • Are you using straight connection HDMI* to HDMI*?
  • Do you remember the previous driver installed?


Please run the following tool in Windows* and attach the report generated. 

  

Intel® System Support Utility (Intel® SSU) 

 

  • Intel® SSU Download
  • Open the application and click on "Scan" to see the system and device information. By default, Intel® SSU will take you to the "Summary View". 
  • Click on the menu where it says "Summary" to change to "Detailed View". 
  • To save your scan, click on "Next", then "Save". 


With the external display connected, provide the Intel* Graphics Command Center report:

 

>Go to the Intel Graphics Command Center

>Support

>System Diagnostic

>Generate report.

>Attach the report file.


Best regards,

Maria R.

Intel Customer Support Technician


Xrijsj
Beginner
440 Views

Are you using straight connection HDMI* to HDMI*?


yes, i have the laptop only 2 monthes
and until before 7 days everything was working fine with FHD and 4K

by the way, the laptop have thunderbolt 3 and display port
and the problem didnt effected on this ports.

both display 4k and fhd.

 

Do you remember the previous driver installed?


i do not remember the previous driver or the original driver which come with the laptop

but i remember that in the day when the problem started, i received windows update from intel:

 

Intel Corporation - Display - 26.20.100.7985 (installed 23/08/2020 , its the day that the problem started)

but i tried uninstall this update, and tried reset the windows few times.

 

Intel Corporation - System - 30.100.2020.7 (installed 17/08/2020)

 

i uploaded the files, sould i also upload report file of when display port / thunderbolt plugged to tv?

with display port and thunderbolt its display fine fhd /4k, no problem there

Xrijsj
Beginner
444 Views

Are you using straight connection HDMI* to HDMI*?

yes

(the laptop have thunderbolt 3 and display port, both display signal with FHD and 4K)

the problem started only with the HDMI.

i have the laptop only 2 monthes, and until 23/08 HDMI was working fine with with FHD / 4K.

 

Do you remember the previous driver installed?

no, but in the same day when the problem started. i received 1 windows update:

Intel Corporation - Display - 26.20.100.7985 (23/08)

Intel Corporation - System - 30.100.2020.7 (17/08)

but reset the windows didnt help.

 

i uploaded the logs, sould i upload more logs of when display port and thunderbolt connected?

IntelSupport
Community Manager
428 Views

Hello Xrijsj,


Thank you for the information and the reports.


The Intel* Graphics card is recognizing 2 active displays, however, according to the report, only the built-in display is connected to the Intel* Card. It is possible that the second monitor is connected to the Nvidia Graphics card, only the equipment manufacturer is capable to confirm this.


As I mentioned before, the best thing to do is using the drivers that are provided by the system manufacturer to eliminate the potential impact caused by loading non-customized drivers (Intel's generic drivers that were not tested on your specific system). The system manufacturers regularly customize Intel generic drivers to meet the needs of their specific system design. In such cases, the use of the Intel generic driver update is not recommended. The generic drivers are not installed through Windows updates and checking the manufacturer website I found that the latest driver available is the version V26.20.100.7985 so it is possible that Windows installed the OEM version. Since is the same version, I would like to provide you a workaround to see if it works.


Please try a clean drivers installation:


  1. Download the latest driver from the OEM website: and save them on the computer:  V26.20.100.7985
  2. Disconnect from the Internet so no new drivers are automatically installed by Windows Update. 
  3. Uninstall the driver and the Intel Graphics Control Panel from Control Panel Programs and Features. 
  4. Restart the computer. 
  5. Confirm in Device Manager Video Adapters the controller is listed as 'Microsoft Basic Display Adapter' > if not, repeat steps 2 through 4. 
  6. If the adapter continues to be listed as ‘Intel HD Graphics’ or similar, and no other Intel Graphics driver is listed under 'Programs and Features' for removal, then it means Windows has switched to a previously installed Legacy driver. At this point we can remove Legacy drivers from Device Manager
    1. Right-click on 'Intel HD Graphics' or similar, and select 'Uninstall Device' 
    2. In the pop-up window make sure 'Delete the driver software for this device' is checked. 
    3. Click on 'Uninstall'
    4. Restart. (Repeat steps 6.1.1 through 6.1.4 until the device gets listed as 'Microsoft Basic Display Adapter') 
  7. Install the driver that was downloaded on step 1
  8. Restart the computer. 
  9. Reconnect to the Internet. 
  10. If the behavior persists, you can try the generic driver from Intel, just follow the same steps but download the Version: 27.20.100.8587  on step 1.



If after all these steps the issue persists, and since you're using a highly customized system. The best will be to continue with the support with Asus*.



Best regards,

Maria R.

Intel Customer Support Technician


Xrijsj
Beginner
392 Views

Hello Maria,
thank you
yes I tried, it's didn't work
and it's displayed 'Microsoft Basic Display Adapter'

the weird part is why it doesn't change to any resolution if I change via 'Display Settings'

and I tried via modes:
Optimus (Intel graphics)
and dGPU (nvidia)

only when I change to FHD via Nvidia Control Panel, I can get signal on TV.

It's really weird problem, 2 months I'm with the laptop and it was ok until the 23/08.

Thunderbolt 3 and DisplayPort ports working fine with FHD and 4K,
It's only the HDMI.

I'm still in contact with Asus about this problem
Maria_R_Intel
Moderator
365 Views

Hello Xrijsj,


Thank you for your response.


It seems like the Nvidia* card is the one handling the external monitor. According to the reports, both displays are active, but only the built-in is handled by the Intel* Card.


I tried to gather more information about the hybrid graphics configuration on your system, but I was unable to find it on the Asus* official website.


Based on this, and as they didn't test the Laptop with the 4K monitor, the best course of action will be to continue the support with them, to use the proper customized drivers, and have detailed information about how the hybrid graphics work on your system.


Best regards,

Maria R.

Intel Customer Support Technician


Maria_R_Intel
Moderator
359 Views

Hello Xrijsj,


I will proceed to close this thread. If you need any additional information, please submit a new question as this thread will no longer being monitored.

 

Best regards,

Maria R.

Intel Customer Support Technician


Reply