Processors
Processors (Intel® Core™, Intel® Xeon®, etc); processor utilities and programs (Intel® Processor Identification Utility, Intel® Extreme Tuning Utility, Intel® Easy Streaming Wizard, etc.)
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
12360 Discussions

i9 9900k UHD 630 connected with DP-cable: Monitor flickers on 144hz

Zystic
Beginner
1,188 Views

Hello, I am using the i9 9900k integrated graphics (UHD 630) on my LG Ultragear 27GL850 monitor as I currently dont have a dedicated GPU - This is a 2560x1440p @144hz monitor. I've connected my computer with Display port cable. I have the  ASUS ROG strix Z390-F GAMING motherboard.

The problem I have is that when I set my refresh-rate to 144hz, my monitor with flicker badly. As long as I start up my computer with the refresh-rate @120hz, I experience no flickering. But as soon as I try 144hz again, the flickering occurs again. If then I set the refresh rate to lower than 100hz (for example 60hz) my monitor will flicker as well. But when I never touch 144hz and just leave it on 120hz and then switch to 60hz, then 60hz won't flicker. 

So basically: If I dont set it to 144hz, everything is fine. But as soon as I set my monitor to 144hz my monitor will flicker, even after switching it back to under 100hz (100-120hz always works).

Things I tried:
- A fresh Windows installation  (am currently running the latest version of Windows 10)
- Installing latest UHD 630 drivers
- Different cable
- Resetting monitor settings
- turning HDR and Adaptive-Sync off
- Lowering resolution 

I hope someone can help me solve this issue or at least figure out the cause of the issue. 

Thanks in advance!

 

 

Labels (1)
0 Kudos
1 Solution
Girthquake
Beginner
1,168 Views
Hi. I dont really know the cause, but I am also experiencing a very similar issue. I have also noticed the fickering in the bios. I found that if I disable adaptive sync and set the aspect ratio to "just scan" in the monitor's OSD, the issue goes away. Hope this helps. This has only happened with my 9900k's iGPU so far. Not with a discreet graphics card.

View solution in original post

2 Replies
Girthquake
Beginner
1,169 Views
Hi. I dont really know the cause, but I am also experiencing a very similar issue. I have also noticed the fickering in the bios. I found that if I disable adaptive sync and set the aspect ratio to "just scan" in the monitor's OSD, the issue goes away. Hope this helps. This has only happened with my 9900k's iGPU so far. Not with a discreet graphics card.
Zystic
Beginner
1,143 Views

Oh my god, thanks so much! Setting my aspect ratio in OSD to ''Just scan'' FIXED it!

Im really happy, thanks so much for taking the time to help me out!

Reply