Community
cancel
Showing results for 
Search instead for 
Did you mean: 
EBrit2
Beginner
1,149 Views

Intel 7700K system and memory/motherborad - what's going wrong, here???

Hello everyone!

 

I have a huge prolem to solve. Or at least, i can't find it so i can solve it properly.

 

I've mounted a Intel Core i7 7700K based system in April 2017. It has a Asus TUF Mark 2 mainboard, 2x16 GB Gb Corsair Vengeance DDR memory, a watercooled solution (Cooler Master Lasterliquid 240 (or something like that) and storage (main storage is a 512 Gb Samsung Evo M.2). The processor was bought in Amazon Spain.

 

It worked with no problems until last November. I had some problems when turning on PC: Windows errors, mainly, wich pointed to memory issues. But sometimes then it even couldn't start BIOS...

I've done several things, including hardware changes, but without sucess.

 

The problem is: my PC only works with memory in Single Channel mode. If i try to put memory in slots 1 and 3 (recommended by Asus), the PC won't start.

 

What i've made:

  • reinstall Windows
  • update BIOS
  • changed motherboard for other with same model /(bought another one)
  • changed memory for other with same model (Corsair made RMA for the memory)
  • try to install memory DIMMs in several memory slots. I've managed to succed only with one DIMM, or with both DIMMs but in Slots 1 and 2 (MB has 4)

 

In this moment PC is running with memory in slots 1 and 2, meaning 32GB in Single Channel. However, i feel that system is not achieving its potential: multitasking is not good, and now i have some rendering problems in Vegas. It says that cannot continue render because os low memory.

 

Someone told me that could be the processor's memory controller, wich could be damaged. I was told even that could be the watercooling's dissipator that could be to much tighten. Well, when i chabged motherboard i kept the dissipator less tighten. And, if it was so, why the system has worked well during almost one and a half year???

 

My question is: i've changed almost everything that could be a problem, hardware related. I'me only missing the processor. Could this be really a processor issue?

Can i contact Intel so I can have some warranty on this?

Should i take the risk and buy another CPU?

 

I can give you further details, if someone could help me. Please ask.

 

(sorry if i gave some gramatical error: i'm from Portugal)

 

Best regards!

Eugenio

0 Kudos
6 Replies
n_scott_pearson
Super User Retired Employee
73 Views

Move your existing two DIMMs from "slots 1 and 2" to "slots 3 and 4". If the operation of the system is identical to what it was, then it is NOT an issue with the memory controllers in the processor.

 

Just thought of something: By "slots 1 and 2", do you mean DDR4DIMM_A1 and DDR4DIMM_A2 or do you mean DDR4DIMM_A1 and DDR4DIMM_B1?

Hint: It should be the latter!

 

When you add two additional DIMMs, they should be absolutely identical to those that you already have. Look carefully; from one year to another, memory vendors will switch to DRAM ICs with different specs, often without changing part or order numbers, and this could affect their interoperability within a channel.

 

Hope this helps,

...S

 

EBrit2
Beginner
73 Views

Hi Scott, and thank you!

 

I should give more precise info about the DIMM slots.

 

The mainboard has 4 slots, wich are identified like this: A1/A2 | B1/B2.

 

I ment that the system works when in slots A1/A2 (single channel).

 

However, i've tested also in slots B1/B2, with the same results (it works single channel). Only when i put the DIMMs with A1/B1 or A2/B2 config (wich are the only that assures Double Channel) the system doesn't boot.

 

Asus manual recommends to put the DIMMs in slots A1 B1 in order to work at 100% and take advantage from the XMP frequencies. However, that does not work. With 2 absolutely identical motherboards.

 

Regarding the DIMMS: they are absolutely identical, bought in kit from Corsair. And i've asked Corsair for a RMA replacement because i tought it was a memory problem. They were absolutely fantastic. They have replaced the DIMMs with new ones, but the result is the same. So, took memory apart from the equation...

 

n_scott_pearson
Super User Retired Employee
73 Views

Ok, yea, you should have included that information.

 

So, there are two possibilities, (1) the BIOS MRC (Memory Reference Code) is not handling things properly, or (2) there is something wrong with the processor.

 

Are you running the latest available BIOS for your board? Have you verified you are running the latest available microcode for your board?

Do you have access to another processor that you could try? (Best option for identifying whether it is the processor itself)

 

...S

EBrit2
Beginner
73 Views

Hi!

 

Well... I've tested with the last BIOS available, and with the previous version. Same results.

 

I don't have access to other cpu... But at this point, i can't imagine other thing than the cpu being the cause... However, the system is fully working in single channel, wich is a kind of strange, no? Or is it normal that cpu could work at 100% in this condition?

n_scott_pearson
Super User Retired Employee
73 Views

According to what you have said, both of the memory controllers are individually working, but attempting to use both simultaneously fails. You also said that you've replaced the board and the same thing occurred. It may be the processor - and you could go through the RMA process and have it replaced - but I would hate to wait all that time to get a replacement only to have the same thing occur. Many repair shops will do a test of a board for you and this would identify whether the processor is the culprit. Have you no options like this you could exercise?

...S

EBrit2
Beginner
73 Views

Hi,

 

Yes, that's like you said...

 

I've replaced the motherboard, and memory, so i believe those are in perfect shape.

 

RMA the processor could be a option, but in fact the time spent in that process is painful... If only Intel could do like Corsair, who made me a Advanced RMA (sent a brand new memory kit and only i've received them i send the RMA kit to them...)

 

I think i have to do further tests in a shop... Let's see if i can provide someone... :)

 

Thank you!

Reply