Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
150 Views

USB 3.0 ports not working but 2.0 ports are working (Windows 10, Dell laptop)

Hi all,

 

My USB 3.0 ports are not working but USB 2.0 port is working.

 

I have this issue for more than a year and I suspect it is due to Windows 10 update from Windows 7. I tried a lot to fix this issue from online forums before but still I don't have a solution and its very frustrating to just have 1 usb 2.0 port working.

 

I believe its due to driver issue. Now in my laptop, I don't see any "Intel USB3.0 eXtensible host Controller" under Universal Serial bus controllers in Device Manager.

 

I tried to install the USB3.0 host controller driver from Dell website and I face the same issue. Also, the driver is supported till Windows 7 only and not Windows 10!

 

In Intel site, I dont see any driver for the Intel 6 series chipset. I am using the updated BIOS (2012 dated) from dell.

 

Below are the information of my system.

Model : Dell Inspiron 14z (N411z) laptop

OS - Windows 10 version 1909 (64 bit)

Processor : Mobile Intel Core i5 2430M (Sand Bridge) - 2nd generation

Chipset : Intel 6 series C200 series

 

Any guidance is highly appreciated.

 

Thanks in advance.

0 Kudos
3 Replies
Highlighted
Super User
55 Views

Sorry, but you are in the wrong forum. For a problem such as this, you need to be in the dell forums. You may want to do a fresh install of w10, or go to the dell site and use their driver update tool.

 

Also, your processor and graphics are not supported on Windows 10.

 

And, there are some wonderfull drivers and such on the dell support page. Alas, none for windows 10:

https://www.dell.com/support/home/us/en/04/product-support/product/inspiron-n411z/drivers

 

Doc

 

Doc (not an Intel employee or contractor)
0 Kudos
Highlighted
Super User
55 Views

I would also update the chipset. The usb3 drivers come from Microsoft, not intel.

 

Doc

 

Doc (not an Intel employee or contractor)
0 Kudos
Highlighted
Beginner
55 Views

Firstly, thanks for your quick response.

 

I agree this is not the right place for my question. But I can't find the right place in Intel website to post it.

 

The reason why I posted in Intel is because I see there are "Intel USB 3.0 eXtensible Host Controller Driver" for "Intel 8/9/100 Series and Intel® C220/C610 Chipset Family" but not for "Intel 6 series C200 chipset family". And driver links from external forums pointing to Intel are not available anymore. I think I got those drivers from Intel log back atleast for Windows 7 .

 

I already went through the Dell link shared by you. 

And I tried installing "Renesas USB3.0 Host Controller Driver", the latest "Intel HM67 Chipset Driver"and "Intel Management Engine Interface Driver" and rebooted my system. But still I don't see any "USB3.0 eXtensible host Controller" under Universal Serial bus controllers in Device Manager and my USB 3.0 are not working.

 

It is confusing to look for the drivers. Dell, Intel and now Microsoft!

0 Kudos