Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
92 Views

Arria 10 config from Flash fail

we have an arria 10 board that is not running/configuring from flash.

This is our second iteration of a board that previously worked from flash.

We know (dont think) it is not the file because we can JTAG the file and it runs fine and we can program an old board and it works.  We can make a very simple design and it also loads from sof but fails from flash.

We can apparently program the flash and verify via quartus and it reports everything is ok.

But it wont pass the config stage when restarted trying to load from flash.

We tried the slowest clock speed (internal) and also tried single bit instead of 4 bit serial flash and it still fails just more slowly.

 

The question is if it is some kind of bitstream error/signal corruption of SPI wouldn't the verify of flash via quartus report a problem? 

 

Any suggestion on how can we verify the failure is with SPI flash signal corruption vs some other problem?

 

thanks

 

 

 

0 Kudos
3 Replies
Highlighted
Employee
81 Views

Hi,


To boot from flash, you will need to select "Active Serial Configuration Scheme" and generate JIC bitstream from SOF bitstream and have it programmed into the flash.


Also, any idea at which stage the configuration fails at? You may refer to the user guide below and probe the appropriate pin,

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/hb/arria-10/a10_handbook.pd... (Page 25)


0 Kudos
Highlighted
Beginner
74 Views

thanks for response.

The nStatus pin goes low in middle of config process.

So we can program that flash via jic without any problem. The programmer has verify enabled and reports everything ok.

Then we power cycle and watch the nStatus and config pins. The nStatus goes low about 1/4 of the way through loading from flash. 

We measured time it takes from power on to config done on a working board which is 37 seconds using 12 Mhz clock and only 1 bit.  We are using active serial.

So the same file and settings the nStatus goes low around 10 seconds after start.

 

same exact file works on an old board but not this one. Same fpga, same flash  chip.

 

We also connected the nconfig to a push button so that we can initiate the config process after a long time after power on to rule out power supply issue. 

 

Same thing happens.

0 Kudos
Highlighted
Employee
62 Views

Ok, so based on your explanation, the nStatus remained LOW during device power up right.


As per the power up sequence, nSTATUS is initially pull low and will be pulled high if all the voltage has reached the recommended value.

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/hb/arria-10/a10_handbook.pd... (Page 25)


It seems like the power supplies on your board is not reaching the recommended operating voltage, can you please check if there is any power integrity issue?


0 Kudos