Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
20762 Discussions

Can't access JTAG Chain

ADhar4
Novice
1,259 Views

i am developed customized Cyclone 5 device board. In that we are using cyclone 5 devices as "5CGXFC7C6F23I7" & Configuration device has "EPCQ512". I trying to download basic program via USB Blaster. It showing following error.

error: can't access jtag chain 

error: operation failed

Based on this problem we checked Programmer driver & board power supply also. But we couldn't resolve the issue. pls help to close this issue.

Configuration pins are connected as per below circuit.

ADhar4_0-1615978933175.png

 

0 Kudos
5 Replies
YuanLi_S_Intel
Employee
1,225 Views

Hi,


For pin connection, please refer to pin connection guidelines for cyclone V.

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/dp/cyclone-v/pcg-01014.pdf


Meanwhile, have you installed the driver properly? Is it detected in Quartus Programmer?




0 Kudos
ADhar4
Novice
1,219 Views

Hi,

    Thanks for your response.

     Design is built based on the pin connection guidelines for cyclone V only.  with the same design, earlier we fabricated boards & programmed through USB blaster. With the same design we re-fabricated the board & try to dump the program. We are facing this problem. We checked the all the voltage levels & assembly process also. Everything is good.

USB blaster program driver is properly installed & it detect on Quartus programmer.

  kindly help me close this issue.

0 Kudos
YuanLi_S_Intel
Employee
1,208 Views

Hi,


Can you try with the debug steps as stated?

https://www.intel.com/content/www/us/en/programmable/support/support-resources/knowledge-base/solutions/rd03312011_647.html#:~:text=Check%20the%20JTAG%20chain%20connectivity,%E2%84%A2%20or%20other%20download%20cable.


So you are saying that the design works previously? But it doenst work for this newly fabricated board?




0 Kudos
ADhar4
Novice
1,197 Views

Ok. Thanks For support. We identified the 2 wires connection between Programmer & Board swapped. So we made 3 boards working fine. 

Mean time one board is not programming, during cross verification Status pin is always low. But this pin is connected to pull up resistor with 2.5V. Also remaining boards this pin showing as 2.5V. What could be the problem?

0 Kudos
YuanLi_S_Intel
Employee
1,189 Views

The Cyclone V device drives the nSTATUS pin low immediately after power-up and releases it after the Cyclone V device exits power-on reset (POR). As a status output, the nSTATUS pin is pulled low to indicate an error during configuration.  


Can you please check if the voltage supply pin is all stable?


0 Kudos
Reply