Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,406 Views

Can't scan JTAG chain - DE0-CV / Win 10

Hello all,  

 

I have purchased my first FPGA recently it is a DE0-CV. I cannot get my computer to access it via JTAG. I am using Windows 10.  

 

- I have tried to use the DE0-CV Control Panel software in both RUN and PROG modes and it throws some error about JTAG. 

-I have tried Quartus Prime 17.1 Lite in both Active Serial and JTAG mode and both of those in RUN and PROG.  

- I have tried Quartus II 14.0 64bit Web Edition in both Active Serial and JTAG mode and both of those in RUN and PROG. 

 

Does anyone have any suggestions? It is a brand new board and very frustrating to have this issue.
0 Kudos
10 Replies
Altera_Forum
Honored Contributor I
112 Views

Hi camrod, 

 

Which error are you getting? 

Check the device manager to ensure the proper installation of the USB blaster. 

Are you able to complete Hardware setup with USB-Blaster in the programmer? If Yes, try auto detect.  

Can you post the screenshots? 

 

Best Regards 

Vikas Jathar  

Intel Customer Support – Engineering 

(Under Contract to Intel)
Altera_Forum
Honored Contributor I
112 Views

Picture upload 1

Altera_Forum
Honored Contributor I
112 Views

Picture Upload 2

Altera_Forum
Honored Contributor I
112 Views

It seems that the full screen pictures look terrible..so here is an updated post with smaller pictures. Note that 2 are from trying JTAG and 2 are from trying active serial.  

 

Thanks
Altera_Forum
Honored Contributor I
112 Views

Hi, 

 

Assuming no hardware issues and board is powered ON.  

1.Have you connected USB Blaster header to board header properly(i.e pin 1 to pin 1 mapping)? 

2.Have you selected right device? 

3.Auto detect and upload the screen short. 

or  

check below link which help in debug 

https://www.altera.com/support/support-resources/knowledge-base/solutions/rd03312011_647.html 

 

 

--- Quote Start ---  

Picture upload 1 

--- Quote End ---  

Error not visible. 

 

Best Regards, 

Anand Raj Shankar 

(This message was posted on behalf of Intel Corporation)
Altera_Forum
Honored Contributor I
112 Views

Hi, 

 

The DE0-DV kit has only one USB port for the embedded USB blaster. Make sure to power on the board and then try again. Have you checked if the DIP switch S10 is in RUN mode. 

 

To configure FPGA in JTAG mode :  

 

1. Ensure that power is applied to the DE0-CV board 

2. Configure the JTAG programming circuit by setting the RUN/PROG slide switch (SW10) to the RUN position  

3. Connect the USB cable provided to the USB Blaster port on the DE0-CV board 

4. The FPGA can now be programmed by using the Quartus II Programmer to select a configuration bit stream file with the .sof filename extension  

 

To configure using AS mode:  

 

1. Ensure that power is applied to the DE0-CV board. 

2. Connect the USB cable provided to the USB Blaster port on the DE0-CV board  

3. Configure the JTAG programming circuit by setting the RUN/PROG slide switch (SW10) to the PROG position. 

4. The EPCS64 chip can now be programmed by using the Quartus II Programmer to select a configuration bit stream file with the .pof filename extension. 

5. Once the programming operation is finished, set the RUN/PROG slide switch back to the RUN position and then reset the board by turning the power switch off and back on; this action causes the new configuration data in the EPCS64 device to be loaded into the FPGA chip.
Altera_Forum
Honored Contributor I
112 Views

I have tried both AS and JTAG in both the RUN and PROG position. And I have rebooted the device after making the changes from RUN/PROG. 

 

Is USB Blaster confirmed working on Windows 10 64bit? I have no exclamation points or anything in device manager.
Altera_Forum
Honored Contributor I
112 Views

From the screenshot, I see that you're using the .JIC file. Can you try with .SOF nd .POF file. You may need to convert the FPGA JIC file to SOF/POF and then try with the steps provided in the earlier post. 

Yes , the USB blaster is supported by Windows 10. I've used it with the Terasic DE0-Nano board. The latest kits come with the USB blaster built-into the MAX CPLD/FPGA on the board. Thus we need only the normal USB cables to connect the system with the board. 

 

Can you also check if any antivirus programs or firewalls are enabled? Sometimes, these programs may prevent the PC from accessing the kit via USB.
Altera_Forum
Honored Contributor I
112 Views

I have tried .JIC, .SOF, .POF. I disabled my firewall and I have no antivirus on the current dev machine. 

 

When I try .SOF from the DE0-CV 'cd'. I put the device in PROG reset it. The leds go dim like they are supposed to. I change the mode in programmer to Active Serial. Select the EPCS64 device. When I click start it says "Error (209025): Can't recognize silicon ID for device 1. A device's silicon ID is different from its JTAG ID. Verify that all cables are securely connected, select a different device, or check the power on the target system. Make sure the device pins are connected and configured correctly." Note: the usercode is 00000000 when I try this. 

 

also when I push start the ULED flashes one time and then the software throws an error
Altera_Forum
Honored Contributor I
112 Views

I have solved my issue. I noticed that sometimes the JTAG debugger would find 10-90 devices after moving the dev board. I knew that it was trying to work but there was an intermittent issue. After examining the board I noticed what looked like trash between two pins on the USB Blaster (MAX II chip). I blew on my board and slapped it gently and Programmer found my device for the first time. After I realized that that was the issue I used my soldering iron to (painstakingly) melt the waste solder that was hung between the two pins.  

 

TL;DR - there was lose solder stuck between two pins of the MAX II CPLD USB Blaster. It would wiggle around but not pull out between the pins. i have included pictures of what it looked like. 

 

Thank you guys for trying to help. :)
Reply