Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MDARG
Beginner
230 Views

Cannot program the FPGA on the Intel Cyclone 10 GX Development Board

Hi all!

 

When I try to program the Intel Cyclone 10 GX on the Cyclone 10 GX Development Board, I always get the Error message:

 

"Can't configure device. Expected JTAG ID code 0x02E120DD for device 2, but found JTAG ID code 0xFFFFFFFF. Make sure the location of the target device on the circuit board matches the device's location in the device chain in the Chain Description File (.cdf)."

 

Although everything is configured properly. Also strange is that it seems like the program is loaded on the FPGA anyway, but after that I cannot access the board via JTAG anymore. Only if I restart the whole board I can program the FPGA again.

 

This is also my second Intel FPGA Development Board.

With my first Intel FPGA Development Board I dont have any problems programming it, also when I use the exact same binary.

 

I would be really grateful if someone had an answer to that.

 

I'm using Intel Quartus Prime Pro 18.1 on Windows 10 (64Bit).

0 Kudos
2 Replies
sstrell
Honored Contributor II
65 Views

In the Quartus Programmer, do you see the device in the chain? If you do an auto detect does the device appear? Also double-check all the board DIP switches to make sure you haven't inadvertently adjusted something that would cause issues with the JTAG chain.

 

If you open a Nios command shell (normal installed with Quartus, access from Start menu) and type "jtagconfig", what do you see, before and after you get in this state?

 

#iwork4intel

MDARG
Beginner
65 Views

Hi,

Thank you for the answer!

Problem was solved when I uncoupled the FMC JTAG chain from the main JTAG chain via DIP switch.

I don't know why this caused a problem, but now it works just fine.

Reply