Community
cancel
Showing results for 
Search instead for 
Did you mean: 
158 Views

Configuration issue between EPCS64 and FPGA

Hello, I am trying to flash program the EPCS64 with Quartus Iii 12.1 version and stratix III and I get this error,

EPCS signature is 0XFF

EPCS device doesn't support RDID command

EPCS identifier and signature are all ones - please check for data stuck high

No EPCS layout data - looking for section [EPCS-FF]

Unable to use EPCS device

I tried replacing EPCS64 twice. So EPCS64 should be fine and also I'm able to directly program EPCS64 using pof file but FPGA is not getting configured from EPCS64.I found that this is the issue between FPGA and EPCS64. Can someone help if you have faced the same problem? Thanks in advance.

0 Kudos
4 Replies
YuanLi_S_Intel
Employee
119 Views

Hi Shwetha,

 

Can you please elaborate more so that i can understand the scenario in a whole picture? May i know, are you saying that you are able to program the EPCS with POF but when you are not able to boot the FPGA with EPCS? If not please clarify.

 

May i know what is the configuration scheme you used?

 

Thank You.

 

Regards,

Bruce

119 Views

Hi Bruce,

Yes, I am able to program EPCS with pof the FPGA is not getting booted from flash. When I try to program using nios II flash programmer I get the error as mentioned in the question. I also tried programming using jic file and I get the error

"can't recognize silicon ID for device 1".

I am using active serial configuration.

Thank you. ​

119 Views

On debugging the issue I got to know that there was short between FPGA_DCLK and GND with an impedence of 25 ohms. So I had xray inspection done on the BGA of fpga to see if there were any shorts. It looked fine. So, the only element left is FPGA. Has this pin of FPGA gone bad? If yes, what might be the reason?Should I have to replace the FPGA?

Can someone please help me out with this. I am stuck since many days. Thanks in advance.

YuanLi_S_Intel
Employee
119 Views

Hi Shwetha,

 

By seeing at the error message, it seems like the device OPN is not selected correctly in Quartus. Also, you will need to select the correct configuration scheme in Quartus.

 

If it is due to device problem, can you try to replace it with another device and test?

 

Thank You

Reply