Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,603 Views

Cyclone 10 GX requires Pro license

I was a bit surprised that the new entry level family requires a Quartus Pro license (the GX version). 

The older Cyclone GX families could be built using the Lite version. 

Is this something which will persist? 

 

The Xilinx Vivado WebPack supports Artix7 devices with 200kLEC's and 16X 6.6Gbps transceivers.
0 Kudos
11 Replies
Altera_Forum
Honored Contributor I
155 Views

Cyclone10 GX is supported in Quartus Prime Pro without any License. 

 

Refer to Quartus download page below. 

http://dl.altera.com/17.1/?edition=pro&platform=windows&download_manager=dlm3 

 

Cyclone 10 GX device support Part 1 (FREE, no license file required) 

Size: 2.3 GB MD5: B580CE388353D676FAFEF693C57C70C2 

Cyclone 10 GX device support Part 2 (FREE, no license file required) 

Size: 3.0 GB MD5: 58C5653666D003F6967919DA68926E20 

 

Also for full comparison among Quartus versions refer to link below. 

 

https://www.altera.com/products/design-software/fpga-design/quartus-prime/download.html 

 

 

Best Regards, 

arslanusman2003 

(This message was posted on behalf of Intel Corporation)
Altera_Forum
Honored Contributor I
155 Views

But the Pro version requires a license? Or are you saying that the device files might be installed into the lite version, or that the pro version can be run without a license if only the 10GX devices are used?

Altera_Forum
Honored Contributor I
155 Views

 

--- Quote Start ---  

Cyclone10 GX is supported in Quartus Prime Pro without any License. 

 

Refer to Quartus download page below. 

http://dl.altera.com/17.1/?edition=pro&platform=windows&download_manager=dlm3 

 

Cyclone 10 GX device support Part 1 (FREE, no license file required) 

Size: 2.3 GB MD5: B580CE388353D676FAFEF693C57C70C2 

Cyclone 10 GX device support Part 2 (FREE, no license file required) 

Size: 3.0 GB MD5: 58C5653666D003F6967919DA68926E20 

 

Also for full comparison among Quartus versions refer to link below. 

 

https://www.altera.com/products/design-software/fpga-design/quartus-prime/download.html 

 

 

Best Regards, 

arslanusman2003 

(This message was posted on behalf of Intel Corporation) 

--- Quote End ---  

 

 

That's not what the O.P. was complaining about. Quartus Prime Pro costs $$$ and is the only version that supports Cyclone10 GX. 

 

Quartus Prime Lite (free) and Standard ($) support Cyclone 10 LP, but not GX. So if you want/need to use Cyclone 10 GX you have to pay $$$ for the software to do it.
Altera_Forum
Honored Contributor I
155 Views

The Intel Cyclone 10 GX device support is available for free in the Pro Edition software.  

 

You can download the Quartus Prime Pro Edition, install Cyclone 10 GX device support and start using it. 

 

 

 

Best Regards, 

arslanusman2003 

(This message was posted on behalf of Intel Corporation)
Altera_Forum
Honored Contributor I
155 Views

Yes, I guess the Lite version only supports the basic few devices for free. You would need to buy the Pro edition which will have support for the C10GX for free. The other devices require a paid subscription. In short, If you need to work on GX devices get the licensed version of the software. That's Intel,s policy.

Altera_Forum
Honored Contributor I
155 Views

I'm still a bit confused whether a pro license has to be purchased or if it can be used for free with the Cyclone 10 GX. I installed and tried to build a small LED flash design. But when I tried to build I got: 

 

Internal Error: Sub-system: DCALC, File: /quartus/ddb/dcalc/dcalc_bcm_modules_cache.cpp, Line: 116 Could not load pdb file - /tools/altera/quartus/v17.1.0.240_pro/quartus/common/devinfo/cyclone10gx/ddb_cyclone10gx_io_48_3v_tile-ff-3-0-hs_model_debug Stack Trace: 0x1129c9: DCALC_TIMING_NETLIST_MANAGER_IMPL::load_model(char const*, bool, DCALC_TIMING_DB_VERSION_ENUM) + 0x49 (ddb_dcalc) ... The file above is not in the installation. The closest match is files named ddb_cyclone10gx_io48_dr_clock_buffer* 

 

 

Does that mean that it's not supported?
Altera_Forum
Honored Contributor I
155 Views

The Quartus Lite versions do not support the GX devices. You cannot install devices that are not supported by the Lite version also. For all other devices not supported in the Lite version, you need to get the Paid Standard or Pro editions. 

 

https://www.alteraforum.com/forum/attachment.php?attachmentid=14525
Altera_Forum
Honored Contributor I
155 Views

 

--- Quote Start ---  

I'm still a bit confused whether a pro license has to be purchased or if it can be used for free with the Cyclone 10 GX. I installed and tried to build a small LED flash design. But when I tried to build I got: 

 

Internal Error: Sub-system: DCALC, File: /quartus/ddb/dcalc/dcalc_bcm_modules_cache.cpp, Line: 116 Could not load pdb file - /tools/altera/quartus/v17.1.0.240_pro/quartus/common/devinfo/cyclone10gx/ddb_cyclone10gx_io_48_3v_tile-ff-3-0-hs_model_debug Stack Trace: 0x1129c9: DCALC_TIMING_NETLIST_MANAGER_IMPL::load_model(char const*, bool, DCALC_TIMING_DB_VERSION_ENUM) + 0x49 (ddb_dcalc) ... The file above is not in the installation. The closest match is files named ddb_cyclone10gx_io48_dr_clock_buffer* 

 

 

Does that mean that it's not supported? 

--- Quote End ---  

 

 

This is a known issue for Quartus Pro 17.1 with Cyclone10 device family installed. 

 

Please refer to KDB for the workaround, this will be fixed in future release of Quartus. 

 

https://www.altera.com/support/support-resources/knowledge-base/tools/2017/internal-error--sub-syste... 

 

 

 

Best Regards, 

arslanusman2003 

(This message was posted on behalf of Intel Corporation)
Altera_Forum
Honored Contributor I
155 Views

 

--- Quote Start ---  

The Quartus Lite versions do not support the GX devices. You cannot install devices that are not supported by the Lite version also. For all other devices not supported in the Lite version, you need to get the Paid Standard or Pro editions. 

 

https://www.alteraforum.com/forum/attachment.php?attachmentid=14525  

--- Quote End ---  

 

 

Allow me to clarify your confusion. 

 

for Cyclone 10 -LP yes you will use Quartus Lite Edition. 

 

for Cyclone 10-GX use Quartus Pro Edition, you can download it for free and install it in your system and start using Cyclone 10 GX device. 

For Arria 10 and Stratix10 device you need to purchase a License.  

 

 

Best Regards, 

arslanusman2003 

(This message was posted on behalf of Intel Corporation)
Altera_Forum
Honored Contributor I
155 Views

 

--- Quote Start ---  

That's not what the O.P. was complaining about. Quartus Prime Pro costs $$$ and is the only version that supports Cyclone10 GX. 

 

Quartus Prime Lite (free) and Standard ($) support Cyclone 10 LP, but not GX. So if you want/need to use Cyclone 10 GX you have to pay $$$ for the software to do it. 

--- Quote End ---  

 

 

Update ... looks like I stand corrected ... in this document: 

 

https://www.altera.com/content/dam/altera-www/global/en_us/pdfs/literature/po/ss-quartus-comparison.... 

 

Footnote (2) is: 2. the intel cyclone 10 gx device support is available for free in the pro edition software. 

 

so it looks like indeed you can download the Pro version and use it for free, but ONLY for the Cyclone 10 GX device family.
Altera_Forum
Honored Contributor I
155 Views

Thank you for making that clear. I did a test, including the Arria 10 devices, and now it works. Thanks!

Reply