Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
Announcements
Need Forum Guidance? Click here

Search our FPGA Knowledge Articles here.
18969 Discussions

Does the Intel Programmable Acceleration Card only support intel scalable xeon processer?

jerrylee
Beginner
262 Views

i have a "Intel® Programmable Acceleration Card with Intel Arria® 10 GX FPGA", i want to develope some OpenCL apps with it.

https://www.intel.com/content/www/us/en/programmable/products/boards_and_kits/dev-kits/altera/accele...

My computer is HP Z600 with two Intel® Xeon(R) CPU X5570 @ 2.93GHz processor , 48GB DDR3 1333 MHz ECC memory, the PCIE may be 2.0

i tried the following Stack Versions, but none of them  worked well, which made me wonder if this card does not support ordinary xeon processors, but only support the scalable xeon processors?? however, Intel officials did not clearly point out that??

1. firstly, i tried the Intel® Acceleration Stack Version 1.2.1 with ubuntu 18.04LTS

(ref:https://www.intel.cn/content/www/cn/zh/programmable/documentation/iyu1522005567196.html)

i could get some infomation, but when i excuted the cmd

 

 

$ sudo fpgainfo fme

 

 

it returned:

 

 

Board Management Controller, microcontroller FW version unavailable
Last Power Down Cause: unavailable
Last Reset Cause: unavailable (can't open)
//****** FME ******//
Object Id : 0xF200000
PCIe s:b:d:f : 0000:0F:00:0
Device Id : 0x09C4
Socket Id : 0x00
Ports Num : 01
Bitstream Id : 0x123456789ABCDEF
Bitstream Version : 1.2.3
Pr Interface Id : ce489693-98f0-5f33-946d-560708be108a
Boot Page : user

 

 

it shows "microcontroller FW version unavailable", but i found the "Pr Interface Id : ce489693-98f0-5f33-946d-560708be108a", it indicates a previous stack Version 1.0 or 1.1 is needed(ref: https://www.intel.com/content/www/jp/ja/programmable/documentation/dnv1485190478614.html#uul14985195...)

2. so ,i tried the Intel® Acceleration Stack Version 1.0 and 1.1 with CentOS 7.4

(https://www.intel.com/content/www/jp/ja/programmable/documentation/dnv1485190478614.html#uul14985195...)

all installation steps were finished by tht guide! but when i want to Identify the FPGA Interface Manager (FIM) Version Loaded, it run the 

$ sudo fpgainfo fme

but it returned:

 

 

WARNING: No sysfs paths found

 

 

Stack Version 1.0 and 1.1 have the same response!!

 

Indeed, i tried it on HP Z840, with more mordern CPU, memory and PCIE, but the

 cmd

 

 

$ sudo fpgainfo fme

 

 

did not work, too! so ,what should i do to solve those hard problems?? 

Do i have to purchase a intel scalable xeon processor?? i just need the OpenCL, the others is not important. 

thanks, I earnestly hope to get your attention and reply

 

 

0 Kudos
2 Replies
ChenSheng
Beginner
207 Views

Hello.

Have you solved it? I encounter the same problem.

ChenSheng
Beginner
183 Views

The message "Board Management Controller, microcontroller FW version unavailable" probably means the BMC firmware version is not compatible with FIM version, because this two have strict correspondence . In my opinion,  you can use bitware tools to check the BMC version through the USB wire and update the BMC firmware to proper version.

Reply