Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
418 Views

Error (12002): Port "I2C_SCL" does not exist in macrofunction "U1"

AM GETTING THIS ERROR WHILE ANALYSINING THE DESIGN

CAN SOMEONE SUGGEST WHAT COULD BE THE PROBLEM...

I have checked the qsys also the name are same and i have also exported the pin

 

THANKS AND REGARDS

0 Kudos
7 Replies
Highlighted
22 Views

Hi,

 

Here are the possible solution for your issue:

 

  1. Check the Qsys system to ensure the missing port exists in the design
  2. If you have duplicates or more than one output folder, please remove the unused output folder, the error might be Qsys confused between the output folders.

 

Let me know if the problem persist.

0 Kudos
Highlighted
Novice
22 Views

hi,

 

thanks for the reply...

as you said i checked the missing port but there is a port in the qsys....

i am attaching the project here... can you please check and let me knw...

 

the qsys design is in the RSU floder-> onchip.qsys

0 Kudos
Highlighted
22 Views

Hi,

 

I will check the project.

 

Meanwhile can you discard any unused project/previous unused project in your folder, or simply create a clean one in a new folder, see if it works.

 

Here is a similar discussion regarding the error in case I am late with the update:

https://forums.intel.com/s/question/0D50P000046IjYRSA0/system-verilog-pass-typedef-struct-packed-bet...

 

Regards.

0 Kudos
Highlighted
Novice
22 Views

hi,

 

as per your suggestion i tried deleting all the unwanted folders and comiling it again but still the same problem persist.

can you let me know whatelse can be done

0 Kudos
Highlighted
22 Views

Hi,

 

Are you using MAX10 board? Also, how did you do the design? Is it from a tutorial that you follow or any guides.

 

Regards.

0 Kudos
Highlighted
Novice
22 Views

am using max10 board. the design is based on the some guidance.

But now am designing I2C communication for that am following the below manual.

https://sites.ualberta.ca/~delliott/ece492/appnotes/2014w/G5_I2C_Driver_Improved/G5%20-%20I2C%20Driv...

0 Kudos
Highlighted
22 Views

Hi,

 

Is the above manual also reporting the same error?

 

If you still facing the error can you do a clean build of the project and share it to me.

0 Kudos