Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Honored Contributor I
1,646 Views

Error when starting SignalTap from MATLAB

The code: 

addpath(genpath('C:\altera\11.1\quartus\bin64')); alt_signaltap_run  

 

Error appear when run alt_signaltap_run. At next, Matlab crashes. 

Q11.1sp2, Matlab 7.12.0 (R2011A), Win7x64 installed. 

--------------------------- Microsoft Visual C++ Runtime Library --------------------------- Assertion failed! Program: ... File: d:/SJ/nightly/11.1/173/w64/p4/qu.../mex_si...ain.cpp Line: 142 Expression: ver_handle For information on how your program can cause an assertion failure, see the Visual C++ documentation on asserts (Press Retry to debug the application - JIT must be enabled) --------------------------- Abort Retry Skip ---------------------------  

 

Why? How to fix it?
0 Kudos
12 Replies
Highlighted
Honored Contributor I
105 Views

You need to add the Quartus bin directory to your system path. 

 

You can either do this by right-clicking on My Computer and selecting Properties, Advanced and then Environment Variables. Then modify the variable PATH to add C:\altera\11.1\quartus\bin64; to the beginning. 

 

Alternatively type the following in MATLAB first: 

 

setenv('path', ['C:\altera\11.1\quartus\bin64;' getenv('path')])
0 Kudos
Highlighted
Honored Contributor I
105 Views

Wow it works!!!!!!!!!!!!! 

Big thanks, dabuk!!!
0 Kudos
Highlighted
Honored Contributor I
105 Views

 

--- Quote Start ---  

Wow it works!!!!!!!!!!!!! 

Big thanks, dabuk!!! 

--- Quote End ---  

 

 

Hi i have same error, I am not able to acquire the jtag.it is showing the same error,i have added the quartus bin directory also.but still i'm getting the same error.but insted of ver_handle its showing mat_handle.anyone have faced this problem ???
0 Kudos
Highlighted
Honored Contributor I
105 Views

Hi,i have the same problem,can anyone help me to resolve this problem,thanks! 

code : 

Microsoft Visual C++ Runtime Library 

--------------------------- 

Assertion failed! 

 

Program: ... 

File: d:/SJ/nightly/11.1/173/w64/p4/qu.../mex_si...ain.cpp 

Line: 142 

 

Expression: mat_handle 

 

For information on how your program can cause an assertion 

failure, see the Visual C++ documentation on asserts 

 

(Press Retry to debug the application - JIT must be enabled) 

--------------------------- 

Abort Retry Skip  

---------------------------
0 Kudos
Highlighted
Honored Contributor I
105 Views

Have you tried the fix I suggested earlier in this thread?

0 Kudos
Highlighted
Honored Contributor I
105 Views

 

--- Quote Start ---  

Hi,i have the same problem,can anyone help me to resolve this problem,thanks! 

code : 

Microsoft Visual C++ Runtime Library 

--------------------------- 

Assertion failed! 

 

Program: ... 

File: d:/SJ/nightly/11.1/173/w64/p4/qu.../mex_si...ain.cpp 

Line: 142 

 

Expression: mat_handle 

 

For information on how your program can cause an assertion 

failure, see the Visual C++ documentation on asserts 

 

(Press Retry to debug the application - JIT must be enabled) 

--------------------------- 

Abort Retry Skip  

--------------------------- 

--- Quote End ---  

 

The Altera Support person told me it is bug in the MATLAB and might be fixed in coming days. 

 

Until then you can open the project in Quaturs and use the same signal tap file directly. 

 

Hope this helps..
0 Kudos
Highlighted
Honored Contributor I
105 Views

I don't think that is a bug in MATLAB. It's caused by the Altera signal tap mex function and the error message is identical to the message previously reported in this thread which is due to Quartus paths not being present in the PATH variable.

0 Kudos
Highlighted
Honored Contributor I
105 Views

I don't think so.I am sure i have add Quartus paths to the PATH variable,but it dose not work! By the way,I use xp(sp30) os

0 Kudos
Highlighted
Honored Contributor I
105 Views

You need to make absolutely sure. 

 

"getenv PATH" is the way to find out. If the string it returns doesn't contain "C:\altera\11.1\quartus\bin64" then it won't work.
0 Kudos
Highlighted
Honored Contributor I
105 Views

 

--- Quote Start ---  

You need to add the Quartus bin directory to your system path. 

 

You can either do this by right-clicking on My Computer and selecting Properties, Advanced and then Environment Variables. Then modify the variable PATH to add C:\altera\11.1\quartus\bin64; to the beginning. 

 

Alternatively type the following in MATLAB first: 

 

setenv('path', ['C:\altera\11.1\quartus\bin64;' getenv('path')]) 

--- Quote End ---  

 

 

 

THANK YOU! 

 

I had to edit the path for my install (intelFPGA now) 

 

Win10. Matlab 2017a. Quartus Lite.  

 

Lifesaver! 

 

I'm curious as to why this is? Does the mex file look for binaries on the path? 

 

Bookmarked.
0 Kudos
Highlighted
Novice
81 Views

the same problem accurs to me, have you solved this problem? I'm using Quartus II 14.1 and Matlab 2016b. Best Regards
0 Kudos
Highlighted
Novice
79 Views

i have the same problem, have you solved it? I'm using Quartus II 14.1 and Matlab 2016b.

 

Best Regards

0 Kudos