Community
cancel
Showing results for 
Search instead for 
Did you mean: 
mstef1
Beginner
786 Views

HI, I have a board with a cyclon iv and EPCS64 but te fpga does not strt the programming cycle. I attached the schematic page and the test program I am using. please any help will be appreciated maurizio stefani

HI,

I have a board with a cyclon iv fpga. I am using the AS programming mode using a EPCS64.

I programmed the EPCS64 but the FPGA is not programmed. I noted:

- nCONFIG signal goes low

but the nStatus does not rise and the programming cycle does no start.

I checked the voltages and all seems OK.

I attached the schematic page and the test program I am using.

please any help will be appreciated

maurizio stefani

email progsel.stefani@gmail.com

I am using the USB blaster II programming, and I have used now Quartus 10 but i cheked with Quartus 13 also (same result).

 

0 Kudos
4 Replies
AnandRaj_S_Intel
Employee
33 Views

HI,

 

  1. Did you test .sof file programming via JTAG configuration, Is it successful?
  • If the .sof file can be configure via JTAG successfully then it is not a power issue since JTAG configuration is successful.
  • If the JTAG configuration with .sof file failed, thus it is a power issue need to check the POR.

 

You can can check the FPGA device POR monitored power supplied if those power supply are ramped up to the appropriate voltage level according to the device datasheet and are stable throughout the operation. The nSTATUS is only release to high when the FPGA device POR monitored power supplied are power up correctly. 

 

page 165->https://www.intel.com/content/dam/altera-www/global/en_US/pdfs/literature/hb/cyclone-iv/cyclone4-han...

 

Let me know if this has helped resolve the issue you are facing or if you need any further assistance.

 

Best Regards,

Anand Raj Shankar

(This message was posted on behalf of Intel Corporation)

mstef1
Beginner
33 Views

hI,

Thank you for your answer,

the 1.2 and 2.5V voltages are rise fastly, the vccio (3.3v) is rising within 2mS.

where I can check the POR timing in quartus?

I am not working with JTAG (because I have the AS programmer only, byte bluster II), then the config time will depend by EPCS64 (this is what I understood).

have you any other suggestions?

thank you

maurizio

mstef1
Beginner
33 Views

HI,

again I checked the nSTATUS signal with and without pull-up resistor. the signal remains "low".

I checked the power voltages and they are ok.

the 1.2 and 2.5V rise fastly, the 3.3V .

please find attached the 3.3V power-up sequence

 

maurizio

 

 

AnandRaj_S_Intel
Employee
33 Views

HI,

 

Check the Recommended Operating Conditions tables

https://www.intel.com/content/dam/altera-www/global/en_US/pdfs/literature/hb/cyclone-iv/cyiv-53001.p...

https://www.intel.com/content/dam/altera-www/global/en_US/pdfs/literature/hb/cyclone-iv/cyclone4-han...

 

Best Regards,

Anand Raj Shankar

(This message was posted on behalf of Intel Corporation)

Reply