Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
20754 Discussions

How to turn off or reduce optimization in questa sim

JSLY
Novice
5,852 Views

I downloaded and installed questasim started edition 2021.2  for quartus prime lite 21.1 and the tool opens up and compiles and starts a simulation, but nothing shows up in the "OBJECS" window, almost acting like it is optimizing everything out?  where is the menu to change optimization to a lower level?  I know this is not related to the source files, because I can run the same simulation in Modelsim and everything works just fine.

0 Kudos
11 Replies
SyafieqS
Moderator
5,834 Views

Hi Jeff,


You can go through below manual related to Modelsim as Modelsim and Questa is similar only different in features supported. In term of usability, this could be same. Below manual is related to object window. Is turn off and on the object window resolve the issue? Close it and go to view click object to on the window and see if it reflect any data objects.


https://www.microsemi.com/document-portal/doc_view/131619-modelsim-user#page=164


0 Kudos
JSLY
Novice
5,819 Views

Thank you for trying but closing the window and reopening the window gives the same results.   the compiler is optimizing out all the net so there is nothing to view?  In the terminal window it says loading the optimized design,  I do not know if this is related to the starter edition license, or if it is a configurable setting some where I can turn off or modify?

0 Kudos
GLT1
New Contributor I
5,809 Views

Adding -voptargs=+acc  to the questa command line will turn off all optimizations and allow all signals to be visible.

0 Kudos
SyafieqS
Moderator
5,800 Views

Hi Jeff,


Have you tried adding -voptargs=+acc  to the questa as suggested below?


0 Kudos
JSLY
Novice
5,779 Views

# reading modelsim.ini
Questa>-voptargs=+acc
# invalid command name "-voptargs=+acc"

 

0 Kudos
GLT1
New Contributor I
5,772 Views

It's part of the vsim command line used to open up questa.

 

vsim -voptargs=+acc <your simulation test bench name>

 

 

JSLY
Novice
5,734 Views

Yes that helps Thank You.   However I hate typing,  is there a way to modify the TCL script or the modelsim.ini to turn off optimization so I can just do on the top menu   Simulate-> Start Simulation-><test bench>  .    right now using that command line vsim -voptargs=+acc <your simulation test bench name>  works just fine until you shut down the questa,  if you restart questa a later time, then you have to type in the vsim arguments all over again.     

0 Kudos
GLT1
New Contributor I
5,704 Views

I'm not sure. You'd have to check the Questa documentation.

 

I just put the command to launch the simulation in a script or makefile and call that to launch the simulation.

 

That way I only have to type it once.

 

0 Kudos
SyafieqS
Moderator
5,586 Views

Jeff,


What I could this of is to save the command in a script, invoke and read it whenever you want launch simulation 

Thus prevent you from typing.



0 Kudos
SyafieqS
Moderator
5,493 Views

Jeff,


Let me know if there is any update or concern at your end




0 Kudos
SyafieqS
Moderator
5,408 Views

We do not receive any response from you to the previous reply that I have provided, thus I will put this case to close pending. Please post a response in the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you with your follow-up questions. 


0 Kudos
Reply