Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
Announcements
Need Forum Guidance? Click here

Search our FPGA Knowledge Articles here.
18462 Discussions

JTAG Detection Problem in MAX7000AE

Balamurugan_V
Beginner
224 Views

Hello all,

I m using EPLD max 7000A series(EPM751AEBI256-7)device . I am programming the device using USB Blaster REV C in Quartus II version 13.0.It shows the following errors.

NOTE: TDI and TMS  are pulled up to 3.3V with 2Kohm resistor  and TCK is pulldown to ground with 2Kohm resistor. 

Error: TDI connection to the first detected device UNKNOWN_E000001 might be shorted to GND.

Error: The TCK and TMS connections to the device before the first detected device UNKNOWN_E000001 might have a problem.

Info: Detected 1 device(s)

Info:Device1: UNKNOWN_E000001

 

In JTAG Debugger also shows TDI is shorted to GND. 

Is there any other way to program?

or should I need to use any other Blaster?

In JTAG connector am giving Vref as 5V .But the VCC I/O pins of EPM751AEBI256-7  to 3.3V .Is it correct or not?

Thanks in advance.

 

0 Kudos
5 Replies
Balamurugan_V
Beginner
222 Views

NOTE : sorry the part number is EPM7512AEBI256-7 in MAX 7000AE series.

ak6dn
Valued Contributor II
206 Views

Those pullup/pulldowns should be ok.

Are you sure your 10p JTAG connector pins are wired correctly to the MAX devices?

I use a TerAsic USB Blaster clone on a test board I designed with a 10p JTAG connector and EPM7064S-PLCC44 and EPM7128S-PLCC84 devices and have no JTAG issues with QuartusIIweb 13.0sp1.

JohnT_Intel
Employee
191 Views

Hi,


Could you share with me your board schematic?


Balamurugan_V
Beginner
183 Views

hello all,

I sort out the problem .blaster is not working properly.

Thanks for your replies.

JohnT_Intel
Employee
170 Views

Hi,


I am glad to hear that the issue is due to the blaster and resolved after changing the blaster.


Reply