Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ABUSI1
Beginner
463 Views

MAX 10 fails wilt .pof after boundary scan test

Hi All ,

 

 

One MAX10(10M16DAF256I7G) out of 20 samples fails during .pof download with Quartus programmer.

nconfig/ nstatus /confdone have 10Kohm pull up at 3.0 volt (that's last power rails at powerup: 1,2 -> 2.5 -> 3.0)

DEV_OE 10 kohm pullup, DEV_CLR 10 kohm pullup.

 

.pof case

PROGRAM fails at 9 %. No log availAble.Confdone and nstatus rise high at the start then go low at the end.

VERIFY fails at 2 %. No log available.Confdone and nstatus rise high at the start then go low at the end.

except nstatus where a glitch to 3.0Volt every 3 msec appears .

ERASE successfully.No log available.Confdone and nstatus rise high at the start then go low at the end.

BLANK CHECK successfully. No log avaialble .Confdone and nstatus rise high at the start then go low at the end,

except nstatus where a glitch to 3.0Volt every 3 msec appears

EXAMINE successfully. No log available.Confdone and nstatus rise high at the start then go low at the end,

 

.sof case

PROGRAM successfully. No log available .Confdone and nstatus rise high at the start and remain high at the end .

Device goes in I/O user mode

 

 

.svf case (via gascon machine )

ERASE,PROGRAM,VERIFY successfully: Confdone and nstatus go High, but device seems not to be in User Mode.

 

is it possible that the device is in a sort of JTAG SECURE MODE ?

Earlier, Device passed through BOUADARY SCAN Test Machine, where .jam programming failed before to switch to .svf

 

Let me know if someone could help .

 

best regards

 

Andrea

0 Kudos
2 Replies
RRomano001
New Contributor I
15 Views

Hi Andrea, I experience similar issues on all my MAX10 board, all of them refuse to program .pof after 1st time.

I see no description on JTAG pin, is 1K pull down on TCK and pullup on TMS TDI?

 

At my side I can erase but never reprogram.

Long time ago similar problem where related to Nconfig and some signal not pulled up correctly, now all board are close to yours.

Try power cycle device then restart jtag server, this way I can load .sof.

few day ago I try'd recompile on version 15.0, .pof loaded like a charm, 18.1 fail. No solution found looking around.

I am working on Linux version.

 

 

ShafiqY_Intel
Employee
15 Views

Hi Andrea,

 

How you issue status as for now? Any improvement?

Did RRomano001's workaround is working for you?

 

Thanks.