Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
896 Views

Problem detecting MAX EPM7128SLC84 with USB Blaster

Hi to everyone! I'm am hoping that someone could help shed some light I am having getting a MAX7000S series CPLD IC to work with my USB Blaster/JTAG.  

 

This is the first time I have really dealt with CPLD/FPGA programming, however I have several Altera based dev boards and have no difficulty detecting them in Quartus via the programmer interface. I need to use 5v logic in the project I am hoping to do using the MAX7128SL chip in place of some traditional discreet logic ICs.  

 

I have purchased 3 MAX7000S ICs and have the same problem. I have mounted a 84 pin socket on some perfboard and made the appropriate connections as per the datasheet to a JTAG pin header. I learned from this webpage http://www.digital-circuitry.com/mylab_ic_prog_jtag_isp.htm that I needed to connect all VCC and Ground pins together to be able to program the device. To be clear, I haven't connected VCC and GND to eachother! :-)  

 

I have checked and double checked the connections and everything 'buzzes out' correctly with the multi meter yet, I still cant get Quartus to see the chip. I have tried powering the IC with 5v as I suspected the USB Blaster may not actually power the chip as with my FPGA dev boards. I've tried adding the MAX7000S chip manually and doing a blank check but that fails every time! Nothing I have tried thus far seems to work! 

 

I'm sure that I must be missing something simple, if anyone can give me a clue what I need to do or check it would be greatly appreciated! 

 

Many thanks!
0 Kudos
1 Reply
Altera_Forum
Honored Contributor I
114 Views

Well weirdly, my circuit just started to work :):). Nothing had changed, it just sat on the desk for an hour or so, perhaps it was some USB issue that my PC just fixed behind the scenes when it went into sleep mode. Perhaps power cycling the PC might have lead to earlier resolution! 

 

In case anyone else lands on this post with the same issue... a couple of things I have learned/confirmed: 

 

The IC does need to have its own power supply as I expected. 

 

All VCC and GND pins must be connected and attached to the power supply.
Reply