Community
cancel
Showing results for 
Search instead for 
Did you mean: 
alex_ander
Beginner
82 Views

Problems interfacing to Arria10

Hello, I just got started with the Arria10 Dev kit revE3.1 and am having some issues

The machine I am working on runs Red Hat Enterprise Linux Workstation 7.8

I have Quartus Prime 17.1 along with the Arria10 Developers Kit Package installed. 

I have been following the User guide for this board and tried running the Board Test System. I got the BTS to run by executing the bts.jar file in the arria10 Developers Kit Package but i have not had much success getting it to work.

I have the board connected to my network and I have the IP address showing on the board but the BTS just says "connecting..." and shows Web Link Address 192.168.1.100 however the board shows 192.168.0.21, I can hit refresh on the BTS which refreshes the board but still the same problem. I can connect to the web server associated with the IP address though. 

When i try to run a design i get an error that says "Failed to get this device. Pleas make sure system console is closed. Close this GUI and check the board connection."

I also see an error in terminal and i'm not sure what that means at the moment. 

SEVERE: java.util.concurrent.ExecutionException: java.lang.NumberFormatException: For input string: "USB-BlasterII on localhost (3-6)"

 

On another note I have also tried following a tutorial on RocketBoards.org to build and install U-boot . I am following the instructions there to program QSPI flash and upon running:

~/intelFPGA_pro/20.1/embedded/embedded_command_shell.sh \
quartus_hps -c 1 -o pv -a 0x0000000 u-boot-splx4.sfp

I get the following error in terminal: 

Error: Unable to detect HPS device
Error: Quartus Prime Programmer was unsuccessful. 0 errors, 0 warnings
    Error: Peak virtual memory: 213 megabytes
    Error: Processing ended: Fri Jan 15 13:42:46 2021
    Error: Elapsed time: 00:00:04
    Error: Total CPU time (on all processors): 00:00:00

 

Thanks for your time!

0 Kudos
2 Replies
Deshi_Intel
Moderator
61 Views

Hi,

BTS is meant for Win OS only so it may not be compatible with Linux OS. If you have Win OS then perhaps you can try out BTS.

Thanks.

Regards,

dlim

alex_ander
Beginner
45 Views

ok, thanks for letting me know.

Would you happen to know why I am having problems talking to the HPS using the HPS programmer? every command I try to talk to the HPS returns an error saying unable to detect HPS device. I am using the arria10 board.  I am not sure why i keep getting this error.

Thanks for your time