Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
821 Views

QSYS with Subsystems Project Archive Problem

Hi, I am building a heirachical design in QSYS using Quartus 15.1.2 on opensuze.  

 

I have created a qsys top system and using the "Add a new subsystem to the current system" qsys gui/tool created subsystems. The tool is working, I can drill into each subsystem and edit it and when I generate the qsys everything is functional. 

 

The problem I am having is when I create an archive of the project using Project Archive and restore the project to a new directory, when I open qsys the subsystems are "not found or could not be instantiated". In the original project I see the subsystems in the System drop down in the IP Catalog but in the restored project they are no longer visible.  

 

I have added the .qip files for each subsystems to my project directory and have tried adding all the files I can find to the archive process but I still end up in the same place when I restore the archive. I attempted the export as .tcl for each subsystem but after that I could not drill down into each of the subsystems to edit them. 

 

If I generate a seperate system using qsys and import that into my top qsys as a subsystem it correctly archives but I cant see any difference in the files generated that would cause the seperate qsys files combined to work when creating the subsystems in qsys does not work.  

 

Ideally I dont want to have to regenerate all of my subsystems as individual qsys systems and regenerate my top unless it is really necessary. 

 

I can re-create this in a simple seperate test project.  

 

Has anyone run into this before? Is this a bug in qsys? I cant find any similar issues on the forum or on the knowledge base. 

 

Any help is appreciated. 

 

Thanks, 

James
Tags (1)
0 Kudos
2 Replies
Highlighted
Valued Contributor III
9 Views

Quartus and/or Qsys (Platform Designer) need pointers to the new locations of the .qsys files. You set this in the IP settings in the Quartus options. 

 

What are the paths/locations before and after archiving?
0 Kudos
Highlighted
Valued Contributor III
9 Views

Hi,  

 

OK so after searching around the project folder qsys generates the subsystem *.qsys files and puts them in an ip folder. When I archive the project and restore it, the ip folder is missing. Checking the project archive dialog I can see the ip folder is not included. 

 

I attempted adding this ip folder to: 

Settings -> IP Settings -> IP Catalog Search Locations -> IP search Directories for the project 

 

(note: do these paths have to be absolute? browsing and selecting includes the full path which isnt great) 

 

however the project archive still didnt find the files. I attempted to add the ip/*.qsys files to the project and while they were detected by the project archive, compilation of the project fails with the top qip and the .qsys files included. 

 

The only way I could get the archive to include the ip/*.qsys files was to manually browse and add them in, but that isnt ideal as it is likely they will be missed eventually. 

 

In the project archive -> advanced -> source control -> auto detect source files -> description it says you can use MISC_FILE in QSF assignements to add extra files however in the .qsf file under the notes at the top altera recommends not modifying the qsf file as it can be auto updated and changes overwritten. I gave it a go anyway but still no luck. 

 

Ideally I want the archive to include all the files necessary to compile the project. Other than manually adding the extra files im a bit stuck on the best way forward. 

 

James
0 Kudos