Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Valued Contributor III
1,319 Views

Quartus 11 sp2 drivers not recognised by Windows 10

I upgraded my machine from windows 7 to windows 10 to find my USB Blaster drivers are not recognised by Windows 10 and I only get errors when trying to manually install by right mouse button over the *.inf file. 

 

I have tried ripping out Quartus and re-installing et cetera. 

 

Nuisance as I have older (and cheaper) MAX II and Cyclone II development boards I am self-learning FPGA design with. 

 

I am running Quartus 11 as it covers both my chips and am not inclined to throw the boards out.  

 

As I already have SP2 of 11 I assume there is no fix? 

 

Would another type of programmer work? USB Blaster II? 

 

I haven't looked at my MAX10 since since have I now lost access to my MAX 10 board? 

 

How many people have to throw old boards out and are then out of pocket? 1,000? 10,000? not enough to care? 

 

Cheers, 

A
0 Kudos
4 Replies
Highlighted
Valued Contributor III
35 Views

Here is the release note for Quartus 11.1sp2. As indicated, Windows 10 is NOT a supported operating system for this release. Windows 7 is. So either downgrade your OS back to Windows 7 (not probably likely at this point, unless you have full disk image backups) or upgrade your Quartus to the latest version 16.0 which is the first one that is officially supported on Windows 10 64bit according to Altera. 

 

Of course, if you need older device support (like Cyclone II) then you must use Quartus 13.0sp1 or earlier, as it was the last version to support Cyclone II. This also restricts you to Windows 7 64bit (or Windows Vista/XP; but not Windows 8/10). 

 

Refer to: https://www.altera.com/support/support-resources/download/os-support.html Table 2 readme files. 

 

In my case I will be running Windows 7 64bit on my design machine until at least 2020 (when Windows 7 goes off official support) and likely even longer (ie, hell freezes over). 

 

 

--- Quote Start ---  

Altera Complete Design Suite Release 11.1 SP2 README.TXT 

======================================================== 

 

This readme.txt file accompanies the Altera Complete Design Suite version 11.1 SP2.  

 

..... 

 

System Requirements 

=================== 

Operating system support 

------------------------ 

* Windows 7 (64 and 32 bit) 

* Windows XP SP2 (64 and 32 bit) 

* Windows XP Pro X64 Edition 

* Windows Vista (64 and 32 bit) 

* Red Hat Enterprise Linux 4.0/5.0 for 32-bit and for AMD64  

or Intel EMT64 64-bit CPUs 

* SUSE Enterprise Linux 11 for 32-bit and for AMD64 

or Intel EMT64 64-bit CPUs 

* CentOS 4/5 for 32-bit and for AMD64  

or Intel EMT64 64-bit CPUs  

--- Quote End ---  

0 Kudos
Highlighted
Valued Contributor III
35 Views

I use windows 7 so I've not tried upgrading. There are forum posts about installing USB blaster drivers on windows 10, so look around. I think you disable device driver signing before doing the install, but I don't know the details.

0 Kudos
Highlighted
Valued Contributor III
35 Views

A - 

 

I think you have two choices for the long-term: 

 

1. Scrap the old boards and buy new boards with devices supported by Quartus Prime, which now officially supports Windows 10 as of v16.0. 

2. Go back to Windows 7 for as long as you want to continue to run old versions of Quartus II. 

 

Or I guess you could try running Linux or Win 7 in a virtual machine. Personally, I would go with# 1. Getting stuck in the past can quickly become more hassle than it's worth. Quartus Prime supports MAX II I believe. And the cost of old Cyclone IV dev kits it pretty darn reasonable. 

 

Good luck.
0 Kudos
Highlighted
Valued Contributor III
35 Views

You might also see if you can use the programmer from the latest Quartus with windows 10 to load an image created with an earlier version that works with your older FPGA. The programmer is available as a separate download so you won't have to install the whole Quartus distribution.

0 Kudos