Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
Announcements
Need Forum Guidance? Click here

Search our FPGA Knowledge Articles here.
19211 Discussions

Starting Modelsim from Quartus with RTL Simulation on Ubunutu 18.04

Sombrero
Beginner
929 Views

Good day everyone,

 

I am working on the latest version of Ubuntu OS (18.04) and I would like to simulate my FPGA designs with Modelsim via the RTL Simulation of the Quartus Prime V18.1 Lite Version. As soon as I want to start a design simulation from Quartus I get the following error messages:

 

Error in startup script:

Initialization problem, exiting.

Initialization problem, exiting.

Initialization problem, exiting.

   while executing

"Transcript::action_log "PROPREAD \"$key\" \"$value\"""

   (procedure "VsimProperties::Init" line 59)

   invoked from within

"VsimProperties::Init $MTIKeypath"

   (procedure "PropertiesInit" line 18)

   invoked from within

"PropertiesInit"

   invoked from within

"ncFyP12 -+"

   (file "/mtitcl/vsim/vsim" line 1)

** Fatal: Read failure in vlm process (0,0)

 

I can start both software packages (Quartus, Modelsim) separately from the terminal however starting Modelsim from Quartus doesn't seem to work.

 

Quartus seems to launch to Modelsim simulation software from the /modelsim_ase/linuxaloem/ directory since I get the same errors when I try to start Modelsim via terminal typing ./vsim at that specific directory... launching Modelsim with ./vsim in /modelsim_ase/bin works, however running ./vsim in /modelsim/linuxaloem/ doesn't. I've searched for hours and got all libpng libraries fixed, went through all helpfull tutorials to get both programs to launch properly but this last problem seems to crack me.

0 Kudos
1 Solution
Bosenraum
Novice
411 Views

I'm not sure if this will solve your problem, but make sure you have the correct location setup in the EDA Tool Options. To change this setting go to Tools > Options, then under 'General' select 'EDA Tool Options' and make sure the path for ModelSim is set to /modelsim_ae/bin instead of /modelsim_ae/linuxaloem.

View solution in original post

5 Replies
Bosenraum
Novice
412 Views

I'm not sure if this will solve your problem, but make sure you have the correct location setup in the EDA Tool Options. To change this setting go to Tools > Options, then under 'General' select 'EDA Tool Options' and make sure the path for ModelSim is set to /modelsim_ae/bin instead of /modelsim_ae/linuxaloem.

Sombrero
Beginner
411 Views

Thank you for your reply, Bosenraum! I am giong to test your suggestion soon. I will tell you if I was seccussfull.

Kenny_Tan
Moderator
411 Views
Still facing the problem?
HMeye6
Beginner
411 Views

I have the same problem and Bosenraum's proposed solution did not to the trick for me :(

 

Any other ideas?

Kenny_Tan
Moderator
411 Views

This issue had been awhile, I would suggest you open a new thread for it.

Reply