Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
Announcements
Need Forum Guidance? Click here

Search our FPGA Knowledge Articles here.
19208 Discussions

TTK failed reading from PHY slave, when PCIe and transceivers used in same project

Rk_Athram
New Contributor I
114 Views

Hi,

We are using PCIe and Transceivers in our project.
we have tested both separately for transceivers and PCIe.

We are able to access transceivers In separate project by using transceivers tool Kit (TTK) but

when  same project integrated with PCIe we are getting error in TTK as

"Jun 14, 2022 4:23:23 PM com.altera.debug.core
SEVERE: TTK failed reading from PHY slave_4000, cannot enable TTK functionality for this PHY. Please verify the reconfig_clk is running and ensure this PHY is not stuck in reset."

 

Please help to solve the error.

is it expected behavior? if NOT how to solve the error?

 

 

 

Thanks,

Rajesh

 

 

 

 

 

0 Kudos
3 Replies
wchiah
Employee
96 Views

HI,


From the error message, it's basically complaining about either you didn't provide reconfig_clk from your board or the transceiver is not released from reset properly.

  • Can you double-check your reconfig_clk (100MHz to 125MHz) and verify your transceiver power-up sequence to ensure calibration is done and both PCS Tx_ready and Rx_ready signal are asserted ?
  • Pls share with me your signal_tap file where you captured all the transceiver status signals from Transceiver PHY reset controller IP
  • Another thing to watch out is did you provide clock frequency to FPGA clkusr pin as transceiver power-up calibration clock ?
  • Another suggestion is pls reduce/disable your JTAG connection chain on board and also reduce the JTAG clock frequency from 24MHz to maybe 16MHz or 6MHz to see if it helps
  • Please ensure the reconfig_clk and reconfig_reset of the transceiver PLL were connect to system clock and reset


Regards,

WeiChuan_C_Intel


Rk_Athram
New Contributor I
85 Views

Hi @WeiChuan_C_Intel

 

 

Issue is Solved as power Up calibration for PCIe is Not completed.

Rk_Athram_0-1655300409374.png

So Transceivers NOT calibrated in integrated project.



Thanks&Regards,

Rajesh

 

wchiah
Employee
72 Views

Hi Rajesh,

 

Glad that your problem is solved. Although not much help I can provide.

Thanks for sharing with me your solution as well. With that, I am setting this case to close status at this time.

I would appreciate taking a moment to fill out the short survey with regards to your experience using Intel Forum.

If our support score is less than 9/10, I will value any feedback you can provide.

 

Looking forward to hear back from you in future.

Regards,

WeiChuan_C_Intel


Reply