Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
Announcements
Need Forum Guidance? Click here

Search our FPGA Knowledge Articles here.
18486 Discussions

Why BSP project ignores "disable generation" ?

RShal4
New Contributor I
528 Views

Hello,

 

I encounter this strange behaviour: I try to disable file generation of speciifc HAL driver file.

 

Yet, although I change it to "-" with "disable generation" and saves the settings

 

I verified that in xml there are addition lines:

 

<IgnoredFileInfo>   <componentName>altera_generic_quad_spi_controller</componentName>   <fileName>altera_generic_quad_spi_controller.c</fileName>   </IgnoredFileInfo>

 

 

 

Yet, on clicking generate bsp, it regenerate the file, and also remove the xml lines from setting, and in gui it also appears as enabled generation.

 

Any idea why it ignores the setting ?

 

I'm using quartus 15.1.

 

Thanks,

ran

0 Kudos
6 Replies
Fawaz_J_Intel
Employee
244 Views

Hello,

May I know if this is related to Nios II software development or something else?

If yes, which version are you using?

 

Thanks

RShal4
New Contributor I
244 Views

Yes, NIOS II /f

IP: altera_nios2_qsys Version: 15.1

 

Thanks for any suggestion,

 

RShal4
New Contributor I
244 Views

Is there any idea ?

We really struggle with it for a long time now.

Thanks

EBERLAZARE_I_Intel
244 Views

Hi,

 

This is a known bug that the option to disable BSP file generation in the Nios II BSP Editor not working properly in older version of Quartus.

 

The workaround is to manually edit, or script updates to the settings.bsp to re-disable the file generation (or to remove the file).

 

Have you try using a newer version of Quartus (17 and up)?

 

Regards.

Broddo
New Contributor I
185 Views

This bug is still present in Quartus 20.1

Are there plans to actually fix this? It's been years at this point. The only thing that's happened in the mean time is that rshal2's fix no longer seems to work. 

rshal2
New Contributor II
244 Views

Hi,

 

We need to use version 15.1 by customer request.

Anyway, I did eventually solved the issue, by changing the driver tab from "default" to its number (I think 13.1 was the only other option except for default),

After doing this change, it all worked as should be.

 

Thanks,

Ranran

Reply