Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Honored Contributor I
713 Views

cyclone iii epcs, software fail to boot

hi, 

 

The design is cyclone iii 3c55 with EPCS128. There is epcs controller in NIOS design. The sof and elf is ok when i use "run as hardware". But the software did not automatic load when power-up. The steps are most followed in this forum: 

 

sof2flash --epcs --input=hw.sof --output=hw.flash 

elf2flash --epcs --after=hw.flash --input=sw.elf -output=sw.flash 

# flash EPCS first with FPGA configuration 

nios2-flash-programmer --cable='USB-Blaster [USB-0]' --epcs --base=0x21000 hw.flash# flash EPCS with Nios firmware 

nios2-flash-programmer --cable='USB-Blaster [USB-0]' --epcs --base=0x21000 sw.flash 

 

I also tried the jic file. the software still cannot load after power-up.  

 

One thing I noticed, after power-up, when i run "nios2-terminal", I can see the result of software running. To my understand, nios2-terminal did not download the software (am i right?). But if i did not run "nios2-terminal", 

software did not run. 

 

What is the problem with my steps? or is there anything I need to check based on the thing of "nios2-terminal"? 

 

I use nios2-10.0 sp1. I suppose there should no epcs patch issue like 9.x. 

 

Thanks very much,
0 Kudos
2 Replies
Honored Contributor I
23 Views

Hi, 

 

I have almost the same problem. Does your software start if you do: 

 

nios2-flash-programmer --epcs --base=0x21000 --go 

 

after power up? This will poke my software into starting, but I can't get it to start automatically at power up.  

 

Mark.
0 Kudos
Honored Contributor I
23 Views

The nios2-flash-programmer has a bug in it, 9.1SP2. When you program EPCS with it, it does not work. Create programming file using Altera Stand Alone Programmer, then burn the file into EPCS.

0 Kudos