Community
cancel
Showing results for 
Search instead for 
Did you mean: 
monk31
Beginner
261 Views

programming flash macronix

 

Hi ,

i want to program Cyclone |V with macronix flash MX25L3235EM2I-10G

(spi 32 Mb)

Is the good solution is to use Quartus 18.1 Pro edition and add a new config config device ?

monk31_0-1600938675753.png

 

Best regards

0 Kudos
7 Replies
NurAiman_M_Intel
Employee
250 Views

Hi,


Thank you for contacting Intel community.


Please be noted that Quartus Prime Pro Edition does not support Cyclone IV. You may use Quartus Prime Standard Edition/ Lite Edition to program Cyclone IV.


https://www.intel.com/content/www/us/en/software/programmable/quartus-prime/download.html


Thanks.


Regards,

Aiman


monk31
Beginner
246 Views

thanks for your response

 

but my question is relative with new flash device

the flash macronix is not in the list when i want to program cyclone |V

and i would like to add to program with my blaster in format JIC

NurAiman_M_Intel
Employee
232 Views

monk31
Beginner
223 Views

yes but with my quartus version (Lite,Standard...), i don't have access to his field

To specify the Configuration device, click the (…) button to select a supported
flash memory device and predefined programming flow

monk31_0-1601322273998.png

 

NurAiman_M_Intel
Employee
214 Views

Hi,


If you are using Intel Quartus Prime Standard Edition software version 18.1.1 and later, you should be able to proceed without any issue. Try to check what software version are you using?


https://www.intel.com/content/altera-www/global/en_us/index/support/support-resources/knowledge-base...


Regards,

Aiman


monk31
Beginner
183 Views

 

 

I use quartus prime edition standard 18.1 and the problem is always present

 

As i showed , on the dialog box "Convert Programming File" , i don't have "..."  box (near of Mode text) to add new flash

in cyclone |V and V

 

monk31
Beginner
167 Views

 

Finally i found my problem

 

I migrated my version to 20.1 and it works 

to program a generic flash , you must use 18.1.1 but this version don't exist on the Download Center Intel

this is 18.1.0 that you can download

 

I save a template xml of my flash , and i want to update my database on the other PC. 

how can do it this operation ?

 

 

Reply