Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
Announcements
Need Forum Guidance? Click here

Search our FPGA Knowledge Articles here.
19206 Discussions

why we can not generate pcie ep ipcore example design?

BQi
Beginner
225 Views

we use below ip config, but we can not generate pcie ep ipcore example design, pls help

0 Kudos
10 Replies
BQi
Beginner
130 Views

the file is pcie.ip

BoonT_Intel
Moderator
130 Views

Hi Sir,

Which quartus version that you using?

BQi
Beginner
130 Views
BoonT_Intel
Moderator
130 Views

Hi Sir,

I tried to generate using your IP file and also get the error during generation. Can you list out which setting that you wish to generate? I think maybe we need turn on one by one and determine which setting cause the error. By the way, do you try other pro version?

BQi
Beginner
130 Views
The all parameter is in *.ip One lane PCIe EP instant We only have QII 19.4
BoonT_Intel
Moderator
130 Views

Hi Sir,

After playing around the setting on by one, I found the culprit is "Address width of accessible PCIe memory space".

The generation errors will occur when we set the value to 63 and 64. It will generate the example design successfully when we set the value to 62 and below.

As temporary work around, can you generate the design using "Address width of accessible PCIe memory space" set to 62 or below?

BQi
Beginner
130 Views
Which tab has The parameter “Address width of accessible PCIe memory space”?
BoonT_Intel
Moderator
130 Views

Avalon-MM Settings Tab

BQi
Beginner
130 Views

only 64 and 32

no other options捕获.JPG

BoonT_Intel
Moderator
130 Views

Hi Sir,

What is the IP that you using and what FPGA device?

Based on the IP file that you attached in this thread early. I am open it with Quartus 19.4 and it give me Avalon-MM Intel S10 Hard IP for PCIe.

And based on this IP, the Avalon-MM setting tab is looks like this screenshot.pcie62.jpg

It is different from your screenshot. And the parameter that I mentioned is the  “Address width of accessible PCIe memory space” as highlight in yellow. You should set it to 62 or below.

Reply