Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,786 Views

Blue Screen: DRIVER_IRQL_NOT_LESS_OR_EQUAL and iaStorB.sys

Hi,

For two days my computer often crashes with a blue screen. The error message in the blue screen says that the stop code is DRIVER_IRQL_NOT_LESS_OR_EQUAL, and what failed is iaStorB.sys.

I have noticed that two days ago the following software was installed:

- windows driver package - intel corporation (iastora) scsiadapter

- windows driver package - intel corporation (iastorb) scsiadapter

- intel rapid storage technology enterprise

I have reinstalled the "intel rapid storage technology enterprise" but the computer still crashes. I have also tried to uninstall "windows driver package - intel corporation (iastorb) scsiadapter" in control panel without success. I have tried to restore a previous state of Windows 10 but I get an error message.

My PC is a Dell Precision Tower 5810, and the OS is Windows 10.

Best regards,

Simone

0 Kudos
3 Replies
Highlighted
Community Manager
177 Views

Hello sicroci,

 

 

As we understand, you need assistance with your Dell Precision Tower 5810, if we infer correctly we will appreciate if you can provide us with the following information:
  • The SSU logs (with all your hardware connected to the PC).

     

     

    1- Go to https://downloadcenter.intel.com/download/26735/ and download the software.

     

    2- When finished downloading it, open it.

     

    3- Attach the file obtained to your reply.
  • During bootup do you see any option besides the MegaRAID controller options "press + "when the system is starting?
  • We advise you to open a ticket with your original equipment manufacturer (OEM) in parallel to this case. Since they are in charge of providing support to your PC.

 

We will be looking forward to your reply.

 

 

Best regards,

 

 

Josh B.

 

Intel® Customer Support Technician

 

Under Contract to Intel Corporation
0 Kudos
Highlighted
Beginner
177 Views

Dear Josh D.,

Thank you for your reply. I have solved the problem by going to the device manager (windows 10), and by updating the driver of the Intel(R) C600+/C220+ series chipset sSATA RAID Controller.

I have a question. I started to have the problem after substituting an HDD with an SSD. I probably didn't correctly do the substitution. In the future, if I want to substitute a disk how can I do that correctly?

Best,

Simone

0 Kudos
Highlighted
Community Manager
177 Views

Hi Simone,

 

 

It's great everything is working now.

 

 

Regarding to your question, I don't see anything that you did wrong when replacing the drive. It looks like the driver had to be updated, but the drive replacement itself was fine.

 

 

Have a nice day.

 

 

Regards,

 

Diego V.

 

0 Kudos