Rapid Storage Technology
Intel® RST, RAID
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
1815 Discussions

Intel RST User Interface disappeared after Windows 10 upgrade


Can I install the Intel® Rapid Storage Technology User Interface without installing a new driver for my RAID Array?

Can I install Intel® Rapid Storage Technology, both Driver and User Interface, and then 'Roll Back Driver' to maintain my functioning RAID Array with the current Driver and get the benefit of the User Interface back? If so, what is proper procedure? Is there a "right" version to pick?

In another thread it seems that there is a Nodrv option when running SetupRST.exe but my driver(s) do(es) not seem to match any of the available downloads at Intel. What is proper procedure & "right" version to pick?

I have a Dell Studio XPS 9100, with Intel(R) Core(TM) i7 CPU 930 @ 2.80GHz, 8MB, BLM, D0, originally Windows7, that was originally equipped with a RAID 1 (mirrored) array and had a functioning Intel RST User Interface. I have upgraded the operation system most recently to Windows 10 Pro (64bit). (I believe I avoided upgrade to Window8 but precise memory currently fails me.) During this upgrade the Intel® RST User Interface vanished. I've done 4 single hard drive replacements; which, seem to have gone perfect each time until the last two. The last two seem to have mirrored fine but the goal was to expand capacity. Although I changed from 2x 1TB drives to 2x 2TB drives, during boot up and any other way I have to look, the capacity still shows as only 1TB, just as it always has. This is a fully functioning PC; so, I don't want to start from scratch with empty hard drives. I'm hoping a functioning Intel RST User Interface will give me the tools to finish the expansion. Further details follow:

My 'System' / 'Device Manager' / 'Storage Controllers' shows:

Intel(R) Desktop/Workstation/Server Express Chipset SATA RAID Controller

Driver Provider: Intel Corporation

Driver Date: 2/22/2017

Driver Version:

Digital Signer: Microsoft Windows

My 'Disk Management' / 'OS (C:)' / 'Hardware' / 'Properties' / 'Driver' shows :

Intel RAID 1 Volume

Driver Provider: Microsoft

Driver Date: 6/21/2006

Driver Version: 10.0.16299.192

Digital Signer: Microsoft Windows

An old (still on Windows7, don't remember source of this file, old Intel RST?) .html file titled "SupportAssist: System Information" shows under MotherBoard:

Manufacturer Dell Inc.

Product 05DN3X

Chipset Intel X58

Southbridge Intel ICH10R

and further down:

Intel(R) ICH8R/ICH9R/ICH10R/DO/5 Series/3400 Series SATA RAID Controller

I interpret this as the chipset is capable for Intel® RST to be able to expand capacity based on this reference https://www.intel.com/content/www/us/en/support/articles/000005807/technologies.html?wapkw=ich+raid https://www.intel.com/content/www/us/en/support/articles/000005807/technologies.html?wapkw=ich+raid

I hope you can answer my questions, above.

Best, Steve J.

0 Kudos
8 Replies
Super User Retired Employee

The RST UI was deleted because the 5 Series chipsets and the 1st Generation Core processors are not supported on Windows 10. There is no right procedure to get this back to how it was. You will have to use this array without the benefit of having a UI (and keep your fingers crossed).

I am sorry, but this is something you should have looked into before upgrading to Windows 10. This is the reality of the situation...



Thanks much for the rapid response!

Unfortunately, I trusted MS to appropriately analyze my computer before they advised that my computer was fully compatible for upgrade to Windows10.

Reading between the lines, the Intel RST User Interface is so intimately connected to the specific driver powering Intel RST that they are inseparable, despite the availability of Windows10 compatible Intel RST (including User Interface) versions and despite having a functional driver (as far as I can tell without a UI). Does that sound correct?

Anyone out there done anything to come up with an appropriate work around for my situation and original questions? Any other software able to substitute for Intel(r) RST User Interface?

I'm curious, Do you have any resources / references / links that would have allowed me to discover this incompatibility in advance since MS failed to discover it? I'm anticipating next time MS asks me to bend over.

Thanks, Steve J.

New Contributor I

Suggest you have a look at my thread which in turn has links to some other threads with real, actionable, usable information:

There is a discussion there that you may find helpful, particularly since you are on the same X58 chipset that is in my machine. Please do make a backup of whatever you have under RAID before trying any of the install steps. What I would suggest is that you determine what level of RAID driver you are using, download the corresponding Intel RST download, and try "SetupRST.exe -Nodrv" to install the relevant user interface.

(You can determine what driver you are using via: Device Manager => (Look for Storage controllers and expand) => (Look for something with Intel and RAID in its name) => Double Click => Driver (Level is in Driver Version).

(As far as I know, there was no way for you to have determined, in advance, that there were no "supported" drivers for these older chipsets, unless you knew in advance to even LOOK for such an issue for the issue to begin with.


Thanks for your very helpful advice. I've made it through most of the links you guided me to. To help with my ignorance, does running "SetupRST.exe –Nodrv" specifically mean right clicking on Windows, selecting Run and typing in "SetupRST.exe –Nodrv" . I want to make sure I understand how to choose the –Nodrv option before I run anything.

Can you now successfully use the UI and is monitoring happening on your RAID array?


My PC seems to be running fine using Driver Version (seems to be from Intel but installed in a W10 update)

I verified that I'm on Windows 10 Pro Version 1709 OS Build:16299.248

My intent is SetupRST.exe –Nodrv with version since this is the first Windows 10 compatible version and the version number is higher than the driver version I'm using. If you or anyone else have successfully tried a higher version I'd certainly like to hear about it.

Thanks Again! Steve J.

New Contributor I

You have to be in the folder that contains the SetupRST.exe file, so I typically open a command prompt, navigate to the folder where I downloaded the setup program, and enter the command.

To be specific, step-by-step:

Click on Windows start area (bottom left on my screen), type cmd

That pops up a list, and "Command Prompt" should be at or near the top.

Right Click on "Command Prompt", select "Run as Administrator"

C:\WINDOWS\System32> CD \Folder\where\you\put\Setup.RST

SetupRST.exe -Nodrv

And, yes, after that, the Intel RST user interface and monitoring service would be installed. The UI must be run as administrator (if you forget, it will happily inform you of that when you try to run it as an ordinary user).


WOW, so very helpful!! After I double check all my emergency back-ups are adequate, I think I can do it with an expectation for success. I'll come back here with a report of my results. Thanks for all your work and interpretation!

Best, Steve J.

P.S. Evidence of my ageing & the advancement of Operating Systems; It has been sooooo looooong since I did a command prompt.


Well, I now have a functioning Intel Rapid Storage Technology user interface (Intel RST). Version SetupRST.exe –Nodrv went fine; as expected based on your excellent guidance/help and previous dedication to the pursuit of an actual solution. Thanks to cube1us2 for his persistence!

Others that find themselves in a similar situation as mine, fully functioning RAID array but upgrade to Windows 10 deleted the Intel RST user interface, may find the information from cube1us2 very helpful in understanding what to try. Just remember to back things up, have a restore point, and make a recovery disk before experimenting. You can read my specifics above and judge your odds of success from how similar your equipment and software specifics are to my own.

I now have the bigger RAID drive I was hoping for. Good luck if you decide to try solutions similar to what worked for me.

The detail I learned was that the size increase is a cooperative effort between Intel RST and Windows Disk Management:

1) Increase size in Intel RST (keep in mind my specifics I started with here)

2) Use Windows Disk Management to create new Volume (what I did) or Expand current volume with the newly available space {both includes formatting, be careful} [probably will add comfort if you look at Disk Management before # 1 to understand the difference before and after you increase size in Intel RST]

3) Wait for Intel RST to Initialize ( this took a while)

4) TaDaaa use new space/volume

Has anyone else, in a situation similar to mine, had success with a higher version of Intel RST? Can you describe what benefits a higher version may offer? I'm interested in highest reliability/functionality but only curious about additional features and am reluctant to jump to a new horse when mine seems to be trotting just fine right now. Anyone using a higher version of Intel RST with a no longer fully supported chipset?

Again, much thanks to cube1us2 for his helpful guidance!!!



I have been researching information about the Intel RST, because although I have Intel Optane Memory installed, I do not have the Intel RST UI installed (I am using Windows 10 Home 64-bit); and, since I am limited as to my experience with using the command line interface (cmd), I am having trouble with using the step-by-step instructions you have laid out above. I can run the cmd under administrator as you have indicated, but CD to the directory I have the SetupRST.exe downloaded to, is not working. The SetupRST.exe file is in my \Downloads folder, however, typing in CD \Users\Downloads\SetupRST.exe -Nodrv is netting me nothing. It just says "cannot find the specified path", or words to that effect. Again, since I am limited in my experience of using the command line interface, perhaps I am missing something essential here in the command I am entering in. Can you help me please?