Community
cancel
Showing results for 
Search instead for 
Did you mean: 
CMcIn1
Beginner
720 Views

Secondary SATA 2tb HDD not showing.. Disk On Controller Unknown error

I have a Samsung Evo 256gb SSD and a Western Digital Green 2tb Sata drive. Both had been working perfectly until recent windows 10 update. 2tb dissapeared. Shows in BIOS and works via USB. Alternative drive doesnt work either and different sata ports makes no difference either. It doesnt show in Device Manager and RST is missing the port however shows in System Report but also shows a Disk On Controller Unknown error on that port. I have attached the system report for your review.

0 Kudos
3 Replies
n_scott_pearson
Super User Retired Employee
63 Views

First of all, if you are not using Optane memory and you are not using RAID, you should not have Intel Rapid Storage Technology installed at all. It is only necessary in these circumstances. I suggest that you uninstall it.

 

I also suggest that you reinstall the latest Chipset Software (a.k.a. INF Update) package. Use this process:

 

  1. Download the latest INF Update package. It is currently located here: https://downloadcenter.intel.com/download/28182/Chipset-INF-Utility?product=1145.
  2. Extract the contents of this ZIP file to a folder on your system disk. For example, you could create and use C:\Windows\Temp\INF.
  3. Open a Command Prompt window and make that folder the current (i.e. enter commands "C:" and "cd C:\Windows\Temp\INF").
  4. Enter command "SetupChipset /overall".
  5. It should ask you to reboot at the end. Do so. If it doesn't ask, do so manually.

 

Also, do you have the Samsung NVMe driver or utility software installed?

 

Hope this helps,

...S

 

CMcIn1
Beginner
63 Views

Thank you for your reply. I have recovered the missing drive and for the interest of someone else trying to solve the same issue, I'll outline what i did:

 

I ran uninstall for the Rapid Storage and it completed successfully.

I then downloaded that INF from the link you provided.

When I wen to run SetupChipset it said I already had a later version so I left the current installed version

I restarted my computer

I noticed Rapid Storage was still in my system tray.

I went into the folder in Program Files and noticed the files were still there but no longer the uninstall program and couldn't run uninstall again.

So got me to thinking about driver issue for the controller.

I went into device manager and under IDE ATA/ATAPI Controllers I ran Update driver on the Intel SATA Controller.

I did let me choose to pick my driver and changed it to Standard SATA AHCI Controller and then restarted my computer and the second drive now shows up.

 

So answer your question, I have no NVMe driver or utility installed. I wasn't aware Rapid Storage was ONLY for Optane and gigabyte installer software showed it so I just installed it without researching (rookie move i know).

 

Thank you very kindly for your assistance

 

n_scott_pearson
Super User Retired Employee
63 Views

You are not alone. I see this all the time. Most, like you, simply install it because it is there in the list. I really wish that the ODMs/OEMs would document these as optional (vs. required).

...S

Reply