Rapid Storage Technology
Intel® RST, RAID
1842 Discussions

Secondary Samsung 980 PRO NVME SSD only detected during Intel RST driver installation?

PdG
Novice
2,786 Views

Greetings Support,

 

I recently purchased an Alder Lake system, but have problems with enabling the secondary NVME SSD (Samsung 980 PRO 2TB) in Windows 11. The drive is detected and visible in the BIOS, but does not show in Windows (or only for a very limited time).

 

The weird thing is: when installing the Intel RST driver, at around 22% into the process, the secondary NVME SSD is detected by Windows 11 (a notification appears) and useable for a little while. During that time I can copy files to it and the drive operates as normal. When the RST driver installation finishes, even before reboot, the drive is ejected again and unavailable in Disk Management again. I can reproduce this behaviour.

 

Hardware
--------
Motherboard: ASUS ROG STRIX Z690-I GAMING WIFI
CPU: 12th Gen Intel(R) Core(TM) i5-12600K
RAM: 2x16GB Crucial DDR5
NVME SSD #1: Samsung SSD 980 PRO 2TB -> connected to CPU, boot drive
NVME SSD #2: Samsung SSD 980 PRO 2TB -> connected to Chipset -> problem drive
SATA SSD: Samsung SSD 870 QVO 4TB -> not relevant here, but added for completeness

 

Software
--------
Windows 11 PRO -> fully updated
Intel_RST_Driver_Software_V19.0.0.1067_WIN10_WIN11_64-bit -> downloaded from ASUS (Z690-I) Product Support page

 

Some observations
-----------------
- Both NVME SSD are technically working correctly. I've switched the drives multiple times and installed Windows on both of them. I've also run self tests and used Samsung Magician for checking the health and performance.

 

- One time, after switching the drives in the motherboard M2 slots, the secondary drive (connected to chipset) was actually active for a short while. During that time I managed to update the firmware of both drives, but shortly after the secondary drive was ejected again.

 

- During the Intel RST driver installation, the Windows Event Viewer generates the following warning: "The application \Device\HarddiskVolume3\Windows\System32\DriverStore\FileRepository\iastorvd.inf_amd64_815480839574a92b\RstMwService.exe with process id 3560 stopped the removal or ejection for the device PCI\VEN_8086&DEV_467F&SUBSYS_86941043&REV_00\3&11583659&0&70.
Process command line: C:\Windows\System32\DriverStore\FileRepository\iastorvd.inf_amd64_815480839574a92b\RstMwService.exe" -> this seems important, but I'm not able to determine what this exactly means.

 

I've attached the SSU scan for review. If necessary, I can also make a video of the driver installation, which shows the timeframe the drive is available and the notification of Windows 11 that a new hardware component is detected.

 

Could you please assist? I'm very confused about this behaviour. It doesn't seem to be a hardware failure, as I can force the drive to become active for a short while (by installing the RST driver)... maybe a firmware issue?

 

Thank you.

0 Kudos
7 Replies
DeividA_Intel
Moderator
2,752 Views

Hello PdG,  

  


Thank you for posting on the Intel® communities.   

  


In order to better assist you, please provide the following:  


1. Does the issue occur with the Intel driver?

2. Did the drives work before with your ASUS ROG STRIX Z690-I GAMING WIFI? If so, when did the issue start?

3. Did you notice the issue with Windows 10?

4. Have you checked with Asus for further steps and recommendations?


Best regards, 


Deivid A.  

Intel Customer Support Technician 


PdG
Novice
2,742 Views

Hi Deivid,

 

Thanks for your quick reply.

 

In regard to your questions:

1. The Intel RST driver obviously has an effect on the secondary NVME SSD. During the installation process of the RST driver, the SSD becomes visible in Windows and I can access it. When the installation process finishes, the SSD gets "ejected" again.

2. As this is a new build (all components are newly bought), the issue started right away. Both SSD drives work as expected in the primary (M.2_1) slot (even before installing the RST driver). I've switched both of them several times and installed Windows on them also several times. In the secondary (M.2_2) slot, the drives only function as expected during installation of the Intel RST driver (repeatable) and once it did function correctly for a couple of minutes right after I've switched them around (not repeatable, I think).

3. I just installed Windows 10 to verify if the problem also occurs on that platform. I can now confirm the problem occurs on both Windows 11 and Windows 10. Also the Intel RST driver shows the exact behaviour (drive becomes visible during installation).

4. Not yet, but I am about to.

 

- I'm very curious what happens around the 22% (progress) mark during the RST driver installation, because something triggers the drive to become active/visible. I think it is worthwhile to know and even thought about disrupting the driver installation process at that specific time to see if it has a positive effect...

 

- The Event Viewer warning also seems interesting and can be linked to the RST driver, although I don't know how to interpret it: "The application \Device\HarddiskVolume3\Windows\System32\DriverStore\FileRepository\iastorvd.inf_amd64_815480839574a92b\RstMwService.exe with process id 3560 stopped the removal or ejection for the device PCI\VEN_8086&DEV_467F&SUBSYS_86941043&REV_00\3&11583659&0&70.
Process command line: C:\Windows\System32\DriverStore\FileRepository\iastorvd.inf_amd64_815480839574a92b\RstMwService.exe"

 

Best regards,

PdG

 

 

DeividA_Intel
Moderator
2,703 Views

Hello PdG, 

  

Thank you for the information provided 


  

I will proceed to check the issue internally and post back soon with more details. 


  

Best regards, 


Deivid A.  

Intel Customer Support Technician 


workparty
Beginner
2,668 Views

thanks for this information

DeividA_Intel
Moderator
2,641 Views

Hello PdG, 



In order to help you further, please try the Intel® Rapid Storage Technology Driver Installation Software with Intel® Optane™ Memory (10th and 11th Gen Platforms) driver.


- Driver: https://www.intel.com/content/www/us/en/download/19512/intel-rapid-storage-technology-driver-install...


Please let me know if the issue persists.



Best regards, 

Deivid A.  

Intel Customer Support Technician 


PdG
Novice
2,609 Views

Hi Deivid,

 

I managed to get it solved.

 

The problem was caused by an extremely "fragile" seating process of the M2 stack on the ASUS Z690-I motherboard. Reseating the M2 stack 15-50 times solves the issue... somehow. Other users reported the same problem. More information can be found here: https://rog.asus.com/forum/showthread.php?127294-ASUS-ROG-STRIX-Z690-I-GAMING-WIFI-secondary-NVME-(M...

 

I still can't explain why the Intel RST driver managed to get the SSD visible and working in Windows during installation of the driver (even with an "incorrectly connected" M2 stack), but I've spent enough time on this already and will leave it at that...

 

Thanks for your support!

 

Regards,

PdG

 

DeividA_Intel
Moderator
2,597 Views

Hello PdG, 



Thanks for the information provided, I do appreciate that you shared how you solved the issue. This will help anyone that may be facing the same issue.


I will close this thread, however, you can open a new one in case you need further support.



Regards,  

Deivid A. 

Intel Customer Support Technician 


Reply