Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ferums
Novice
355 Views

Secondary internal disk shows up as removable.

Jump to solution

Hi, I have Lenovo C730 with 512 GB M.2 drive and secondary 1 TB HDD. Windows 10 1909 thinks that secondary drive is removable. I have latest Intel RST installed.

I have tried this - https://support.microsoft.com/en-us/help/3083627/internal-sata-drives-show-up-as-removeable-media

And this - https://superuser.com/questions/745228/driver-policies-tab-not-showing-in-windows

But none of these solution works. After restart my secondary drive still shows up as removable. How I can "tell" Windows that it's internal? Does Intel RST has different registry entries for this?

Some pictures - https://imgur.com/a/HPbWxoz

0 Kudos
1 Solution
ferums
Novice
147 Views

Few days ago I found solution (or workaround, call it whatever you want) which will disable safely remove option for secondary disk drive while Intel RST is installed and running.

 

1. Open Device Manager, find your HDD or SSD and open its Properties

2. Select Details tab and choose Device instance path

4. Note the visible value and close Device Manager

1.PNG

5. Open Registry Editor and under HKLM\SYSTEM\CurrentControlSet\Enum find your HDD or SSD by value you noted before

7. Find Capabilities key and note its value, in my case it was 100

2.png

8. Right click on key folder and select Copy Key Name, then close Registry Editor

9. Open Task Scheduler and create new task -

· Change User or Group: set it to SYSTEM

· Configure for: chose your platform

· Triggers tab > New > Begin the task > At startup

· Actions tab > New

- Program/script: reg.exe

- Add arguments: add "paste your copied key name here" /v Capabilities /t REG_DWORD /d <your Capability number minus 4 here> /f

 

Example: add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\SCSI\Disk&Ven_WDC&Prod_WD10EZRZ-00HTKB0\4&1d1e5f&0&000200" /v Capabilities /t REG_DWORD /d 96 /f

 

10. Restart your computer and be happy now

3.png

 

To undo the changes you made above, simply remove created task and reboot.

Without the scheduled task, the system will automatically restore the registry value back to their original after a reboot.

 

Source: http://www.paralint.com/blog/2008/11/13/stop-internal-drive-showing-up-in-safely-remove-hardware/

 

Remember, this is only for Intel RST. If your are using Microsoft Standard AHCI controller, you can use this solution: https://support.microsoft.com/en-us/help/3083627/internal-sata-drives-show-up-as-removeable-media

View solution in original post

6 Replies
n_scott_pearson
Super User Retired Employee
147 Views

I think this is an issue in BIOS configuration. You need to change it to not support removability attribute.

H​ope this helps,

...S ​

ferums
Novice
147 Views

C730 BIOS has no any settings related to Hot-Swap, Hot-Plug or any other removability settings.

 

When I completely uninstall Intel RST and add registry entry provided by Microsoft in first link I posted before, internal drive does not show up as removable any more. But after I install Intel RST, drive shows up as removable again, despite of registry entry I added before. I have tried Intel RST provided by Lenovo and from Intel, same results.

n_scott_pearson
Super User Retired Employee
147 Views

What is the problem you are trying to solve? Being considered removable does not stop you from enabling caching on the drive, so there's no performance issue (at least I would have thought).

...S

ferums
Novice
147 Views

Well it's not a problem but something I don't like. 😁

Previously I had a laptop and secondary drive never showed up as removable. I work with different equipment every day, including external drives and USB memories. And couple of times by accident I have "safe" removed my internal drive not external drive or usb memory I have connected to computer. And it's annoying because I need to restart my computer to get back my internal drive.

Probably I will get used to it by the time. 😄 But I'm just wondering why none of possible solutions about this you can find on Google doesn't work with Intel RST.

n_scott_pearson
Super User Retired Employee
147 Views

It's likely because the parameters are specific to the Microsoft Storage Driver and, while RST is installed, the Intel Storage Driver is in use (i.e. the patch simply doesn't apply).

 

As I said, this is normally configured in the BIOS. I would not consider it to be normal that the BIOS doesn't have parameters for configuring this feature. I would be contacting the board manufacturer regarding this issue.

 

Hope this helps,

...S

ferums
Novice
148 Views

Few days ago I found solution (or workaround, call it whatever you want) which will disable safely remove option for secondary disk drive while Intel RST is installed and running.

 

1. Open Device Manager, find your HDD or SSD and open its Properties

2. Select Details tab and choose Device instance path

4. Note the visible value and close Device Manager

1.PNG

5. Open Registry Editor and under HKLM\SYSTEM\CurrentControlSet\Enum find your HDD or SSD by value you noted before

7. Find Capabilities key and note its value, in my case it was 100

2.png

8. Right click on key folder and select Copy Key Name, then close Registry Editor

9. Open Task Scheduler and create new task -

· Change User or Group: set it to SYSTEM

· Configure for: chose your platform

· Triggers tab > New > Begin the task > At startup

· Actions tab > New

- Program/script: reg.exe

- Add arguments: add "paste your copied key name here" /v Capabilities /t REG_DWORD /d <your Capability number minus 4 here> /f

 

Example: add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\SCSI\Disk&Ven_WDC&Prod_WD10EZRZ-00HTKB0\4&1d1e5f&0&000200" /v Capabilities /t REG_DWORD /d 96 /f

 

10. Restart your computer and be happy now

3.png

 

To undo the changes you made above, simply remove created task and reboot.

Without the scheduled task, the system will automatically restore the registry value back to their original after a reboot.

 

Source: http://www.paralint.com/blog/2008/11/13/stop-internal-drive-showing-up-in-safely-remove-hardware/

 

Remember, this is only for Intel RST. If your are using Microsoft Standard AHCI controller, you can use this solution: https://support.microsoft.com/en-us/help/3083627/internal-sata-drives-show-up-as-removeable-media

View solution in original post

Reply